summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-22 22:33:38 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-22 22:33:38 +0000
commit0bcb2c1a470eb71aae8accc1bc31227ffb9d3beb (patch)
treef21ca6583eae9cceed07a0cad8ba6b047c8b216a /sys-apps
parentImport changes from gentoo-alt overlay for building on OpenBSD. Thanks to Ben... (diff)
downloadgentoo-2-0bcb2c1a470eb71aae8accc1bc31227ffb9d3beb.tar.gz
gentoo-2-0bcb2c1a470eb71aae8accc1bc31227ffb9d3beb.tar.bz2
gentoo-2-0bcb2c1a470eb71aae8accc1bc31227ffb9d3beb.zip
Version bump.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-5.96.ebuild149
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.966
3 files changed, 161 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 375a3e99bd12..19afcc0c2285 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.169 2006/05/13 15:36:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.170 2006/05/22 22:33:38 vapier Exp $
+
+*coreutils-5.96 (22 May 2006)
+
+ 22 May 2006; Mike Frysinger <vapier@gentoo.org> +coreutils-5.96.ebuild:
+ Version bump.
*coreutils-5.95 (13 May 2006)
diff --git a/sys-apps/coreutils/coreutils-5.96.ebuild b/sys-apps/coreutils/coreutils-5.96.ebuild
new file mode 100644
index 000000000000..4cf3c61b2666
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-5.96.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.96.ebuild,v 1.1 2006/05/22 22:33:38 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+PATCH_VER=1.0
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~kingtaco/mirror/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="acl nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( sys-apps/acl sys-apps/attr )
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.49
+ =sys-devel/automake-1.8*
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/m4-1.4-r1
+ sys-apps/help2man"
+
+pkg_setup() {
+ # fixup expr for #123342
+ if [[ $(/bin/expr a : '\(a\)') != "a" ]] ; then
+ if [[ -x /bin/busybox ]] ; then
+ ln -sf /bin/busybox /bin/expr
+ else
+ eerror "Your expr binary appears to be broken, please fix it."
+ eerror "For more info, see http://bugs.gentoo.org/123342"
+ die "your expr is broke"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ PATCHDIR="${WORKDIR}/patch"
+
+ EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
+
+ # Apply the ACL/SELINUX patches.
+ if use selinux ; then
+ EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
+ ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
+ elif use acl ; then
+ EPATCH_MULTI_MSG="Applying ACL patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
+ chmod a+rx tests/sort/sort-mb-tests
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ tc-is-cross-compiler && touch man/*.1
+ # There's no reason for this crap to use the private version
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c
+
+ export WANT_AUTOMAKE=1.9
+ export WANT_AUTOCONF=2.5
+ ebegin "Reconfiguring configure scripts (be patient)"
+ aclocal -I m4 || die "aclocal"
+ autoconf || die "autoconf"
+ automake || die "automake"
+ eend $?
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ local myconf=""
+ [[ ${USERLAND} == "GNU" ]] \
+ && myconf="${myconf} --bindir=/bin" \
+ || myconf="${myconf} --program-prefix=g"
+
+ use static && append-ldflags -static
+ econf \
+ --enable-largefile \
+ --without-included-regex \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ ${myconf} \
+ || die "econf"
+ emake || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -f "${D}"/usr/lib/charset.alias
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+
+ # remove files provided by other packages
+ rm "${D}"/bin/{kill,uptime} # procps
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
+ # provide by the man-pages package
+ rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
+ rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
+ rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
+
+ insinto /etc
+ newins src/dircolors.hin DIR_COLORS
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.96 b/sys-apps/coreutils/files/digest-coreutils-5.96
new file mode 100644
index 000000000000..c79c9599395f
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-5.96
@@ -0,0 +1,6 @@
+MD5 4a060388a06c290897000d5861d42d8d coreutils-5.96-patches-1.0.tar.bz2 62297
+RMD160 b5e5f8e9427d8130bcf9dde455e8abbe4566cbe2 coreutils-5.96-patches-1.0.tar.bz2 62297
+SHA256 26fdcabe4a55d012fe8224f4dcfa0994137ae25eb4bafe11e2c47109ec8ba6b1 coreutils-5.96-patches-1.0.tar.bz2 62297
+MD5 bf55d069d82128fd754a090ce8b5acff coreutils-5.96.tar.bz2 5066612
+RMD160 a875565fd5c17dd19b188fde7f3aa2f862743084 coreutils-5.96.tar.bz2 5066612
+SHA256 7d0a6b5d87b5d68674213aa7e264d96ab7c3c0b4264fcc82fbc54920b1a37fcc coreutils-5.96.tar.bz2 5066612