summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-23 17:04:01 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-23 17:04:01 +0000
commit1755155b2c724679f5f97067e717f3cf165ac33b (patch)
treea9e6a6943d6df1a7883bbbcbf0af9254c11d24c2 /sys-apps
parentVersion bump. Remove old. (diff)
downloadgentoo-2-1755155b2c724679f5f97067e717f3cf165ac33b.tar.gz
gentoo-2-1755155b2c724679f5f97067e717f3cf165ac33b.tar.bz2
gentoo-2-1755155b2c724679f5f97067e717f3cf165ac33b.zip
Add USE=perl to control the perl chkdupexe script #284093 by Diego E. Pettenò.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/metadata.xml1
-rw-r--r--sys-apps/util-linux/util-linux-2.16.1.ebuild10
-rw-r--r--sys-apps/util-linux/util-linux-9999.ebuild10
4 files changed, 23 insertions, 5 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index c7644a6bf0cb..4eaa2a5685d7 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.276 2009/09/07 13:41:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.277 2009/09/23 17:04:01 vapier Exp $
+
+ 23 Sep 2009; Mike Frysinger <vapier@gentoo.org> util-linux-2.16.1.ebuild,
+ util-linux-9999.ebuild, metadata.xml:
+ Add USE=perl to control the perl chkdupexe script #284093 by Diego E.
+ Pettenò.
*util-linux-2.16.1 (07 Sep 2009)
diff --git a/sys-apps/util-linux/metadata.xml b/sys-apps/util-linux/metadata.xml
index 1dc54bd13fdc..6c7b30308f37 100644
--- a/sys-apps/util-linux/metadata.xml
+++ b/sys-apps/util-linux/metadata.xml
@@ -4,5 +4,6 @@
<herd>base-system</herd>
<use>
<flag name='loop-aes'>include support for Loop AES encryption</flag>
+ <flag name='perl'>install the chkdupexe helper script</flag>
</use>
</pkgmetadata>
diff --git a/sys-apps/util-linux/util-linux-2.16.1.ebuild b/sys-apps/util-linux/util-linux-2.16.1.ebuild
index 7649eb14329e..cfaf7dc0a618 100644
--- a/sys-apps/util-linux/util-linux-2.16.1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.16.1.ebuild,v 1.1 2009/09/07 13:41:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.16.1.ebuild,v 1.2 2009/09/23 17:04:01 vapier Exp $
EAPI="2"
@@ -25,13 +25,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
+IUSE="crypt loop-aes nls old-linux perl selinux slang uclibc unicode"
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
>=sys-libs/ncurses-5.2-r2
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
+ perl? ( dev-lang/perl )
selinux? ( sys-libs/libselinux )
slang? ( sys-libs/slang )"
DEPEND="${RDEPEND}
@@ -77,6 +78,11 @@ src_install() {
emake install DESTDIR="${D}" || die "install failed"
dodoc AUTHORS NEWS README* TODO docs/*
+ if ! use perl ; then #284093
+ rm "${D}"/usr/bin/chkdupexe || die
+ rm "${D}"/usr/share/man/man1/chkdupexe.1 || die
+ fi
+
# need the libs in /
gen_usr_ldscript -a blkid uuid
# e2fsprogs-libs didnt install .la files, and .pc work fine
diff --git a/sys-apps/util-linux/util-linux-9999.ebuild b/sys-apps/util-linux/util-linux-9999.ebuild
index b6d53f5a85f8..b6edbfe95ffd 100644
--- a/sys-apps/util-linux/util-linux-9999.ebuild
+++ b/sys-apps/util-linux/util-linux-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.10 2009/07/26 16:58:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-9999.ebuild,v 1.11 2009/09/23 17:04:01 vapier Exp $
EAPI="2"
@@ -25,13 +25,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
+IUSE="crypt loop-aes nls old-linux perl selinux slang uclibc unicode"
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
>=sys-libs/ncurses-5.2-r2
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
+ perl? ( dev-lang/perl )
selinux? ( sys-libs/libselinux )
slang? ( sys-libs/slang )"
DEPEND="${RDEPEND}
@@ -78,6 +79,11 @@ src_install() {
emake install DESTDIR="${D}" || die "install failed"
dodoc AUTHORS NEWS README* TODO docs/*
+ if ! use perl ; then #284093
+ rm "${D}"/usr/bin/chkdupexe || die
+ rm "${D}"/usr/share/man/man1/chkdupexe.1 || die
+ fi
+
# need the libs in /
gen_usr_ldscript -a blkid uuid
# e2fsprogs-libs didnt install .la files, and .pc work fine