summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-31 13:12:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-31 13:12:38 +0000
commit1c50fc61fd66f4a937bddc35d5e265cfe31bc94b (patch)
treed075fcfcfbacc9e05c2ffdcaa30b5ff0dcf6bf1a /sys-apps
parentAdd a function to generate dep-strings conditional to Python implementations. (diff)
downloadgentoo-2-1c50fc61fd66f4a937bddc35d5e265cfe31bc94b.tar.gz
gentoo-2-1c50fc61fd66f4a937bddc35d5e265cfe31bc94b.tar.bz2
gentoo-2-1c50fc61fd66f4a937bddc35d5e265cfe31bc94b.zip
Version bump (no update in a few days). Solve bug #446578 while at it.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog8
-rw-r--r--sys-apps/hwids/hwids-20121227.ebuild (renamed from sys-apps/hwids/hwids-20121225.ebuild)24
2 files changed, 24 insertions, 8 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index 2bd64c9992cf..88ec237e1a84 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.59 2012/12/29 17:31:55 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.60 2012/12/31 13:12:38 flameeyes Exp $
+
+*hwids-20121227 (31 Dec 2012)
+
+ 31 Dec 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20121227.ebuild,
+ -hwids-20121225.ebuild:
+ Version bump (no update in a few days). Solve bug #446578 while at it.
29 Dec 2012; Raúl Porcel <armin76@gentoo.org> hwids-20121119.ebuild:
alpha/m68k/s390/sh/sparc stable wrt #436186
diff --git a/sys-apps/hwids/hwids-20121225.ebuild b/sys-apps/hwids/hwids-20121227.ebuild
index bf30eabae815..6d9eb92f17e6 100644
--- a/sys-apps/hwids/hwids-20121225.ebuild
+++ b/sys-apps/hwids/hwids-20121227.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121225.ebuild,v 1.1 2012/12/25 09:41:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121227.ebuild,v 1.1 2012/12/31 13:12:38 flameeyes Exp $
EAPI=5
inherit udev
@@ -20,15 +20,25 @@ RDEPEND="!<sys-apps/pciutils-3.1.9-r2
S=${WORKDIR}/hwids-${P}
-src_configure() {
- MAKEOPTS+=" UDEV=$(usex udev)"
- MAKEOPTS+=" DOCDIR=${EPREFIX}/usr/share/doc/${PF}"
- MAKEOPTS+=" MISCDIR=${EPREFIX}/usr/share/misc"
- MAKEOPTS+=" HWDBDIR=${EPREFIX}$(udev_get_udevdir)/hwdb.d"
- MAKEOPTS+=" DESTDIR=${D}"
+src_compile() {
+ emake UDEV=$(usex udev)
+}
+
+src_install() {
+ emake UDEV=$(usex udev) install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
}
pkg_postinst() {
+ # until udev introduces a way to compile the database at a given
+ # location, rather than just /, we can't do much on offset root.
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+
if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
udevadm hwdb --update
fi