summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-24 21:46:41 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-24 21:46:41 +0000
commit1e8f1a8a968df9f846c18541b26e65cfccab2cb1 (patch)
tree3f03350c1a6eeafe31fae915619fe0a8f78d0905 /sys-apps
parenttweaked changelog (diff)
downloadgentoo-2-1e8f1a8a968df9f846c18541b26e65cfccab2cb1.tar.gz
gentoo-2-1e8f1a8a968df9f846c18541b26e65cfccab2cb1.tar.bz2
gentoo-2-1e8f1a8a968df9f846c18541b26e65cfccab2cb1.zip
bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/parted/ChangeLog7
-rw-r--r--sys-apps/parted/files/digest-parted-1.6.51
-rw-r--r--sys-apps/parted/parted-1.6.5.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index ff72efec5629..0ed0442b5e12 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/parted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.11 2003/02/12 09:04:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.12 2003/02/24 21:46:31 lostlogic Exp $
+
+*parted-1.6.5 (24 Feb 2003)
+
+ 24 Feb 2003; Brandon Low <lostlogic@gentoo.org> parted-1.6.5.ebuild files/digest-parted-1.6.5 :
+ Bump, ebuild fixage, keywords to ~
*parted-1.6.4 (08 Dec 2002)
diff --git a/sys-apps/parted/files/digest-parted-1.6.5 b/sys-apps/parted/files/digest-parted-1.6.5
new file mode 100644
index 000000000000..a7eda273b070
--- /dev/null
+++ b/sys-apps/parted/files/digest-parted-1.6.5
@@ -0,0 +1 @@
+MD5 8a5be3262685d0854165960d31392a94 parted-1.6.5.tar.gz 1168153
diff --git a/sys-apps/parted/parted-1.6.5.ebuild b/sys-apps/parted/parted-1.6.5.ebuild
new file mode 100644
index 000000000000..63f672793475
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.5.ebuild,v 1.1 2003/02/24 21:46:31 lostlogic Exp $
+
+IUSE="nls static readline"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/parted"
+KEYWORDS="~x86 ~ppc ~sparc "
+DEPEND="virtual/glibc
+ >=sys-apps/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ readline? ( >=sys-libs/readline-4.1-r4 )"
+RDEPEND="${DEPEND} =dev-libs/progsreiserfs-0.3.0*"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use readline || myconf="${myconf} --without-readline"
+ [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --disable-debug"
+ use static && myconf="${myconf} --enable-all-static"
+ econf --target=${CHOST} ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog \
+ INSTALL NEWS README THANKS TODO
+ docinto doc; cd doc
+ dodoc API COPYING.DOC FAQ FAT USER USER.jp
+}