summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-06 15:55:07 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-06 15:55:07 +0000
commit207e98968978a19827f5c799e692cc551b202b06 (patch)
tree67ec1a5a9433b43de85da71c3a18036ac40e352b /sys-apps
parentfix bug 36008 on alpha by replacing -Os with -O (diff)
downloadgentoo-2-207e98968978a19827f5c799e692cc551b202b06.tar.gz
gentoo-2-207e98968978a19827f5c799e692cc551b202b06.tar.bz2
gentoo-2-207e98968978a19827f5c799e692cc551b202b06.zip
fix bug 36008 on alpha by replacing -Os with -O
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/groff/ChangeLog9
-rw-r--r--sys-apps/groff/Manifest4
-rw-r--r--sys-apps/groff/files/digest-groff-1.18.1-r42
-rw-r--r--sys-apps/groff/groff-1.18.1-r4.ebuild124
4 files changed, 135 insertions, 4 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 40600d72304d..fe7b1da3aab5 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/groff
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.32 2003/12/15 19:30:13 agriffis Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.33 2004/01/06 15:54:59 agriffis Exp $
+
+ 06 Jan 2004; Aron Griffis <agriffis@gentoo.org> groff-1.18.1-r4.ebuild:
+ Fix bug 36008 by replacing -Os with -O on alpha. Additionally make the build
+ more deterministic by using use_enable for cjk instead of only adding
+ --enable-multibyte.
15 Dec 2003; <agriffis@gentoo.org> groff-1.18.1-r3.ebuild:
ia64 keyword disappeared! Added it to 1.18.1-r3
diff --git a/sys-apps/groff/Manifest b/sys-apps/groff/Manifest
index c58b6fb17c51..1258c29388a5 100644
--- a/sys-apps/groff/Manifest
+++ b/sys-apps/groff/Manifest
@@ -1,5 +1,5 @@
-MD5 2e374874861a6230ea33a70e9abb2923 ChangeLog 5141
-MD5 e7f920243ef6bc1b55ae4fdf0251016c groff-1.18.1-r4.ebuild 3235
+MD5 7b0368326340689ef9b40e841e09dc53 ChangeLog 5141
+MD5 e311733cb9760aaa41e783959a4f658a groff-1.18.1-r4.ebuild 3234
MD5 d6979b73b93de07176e26ea26a8de916 groff-1.18.1-r3.ebuild 3081
MD5 5be96cb38e9dfa7d9e033aafa0a5214d groff-1.18.1-r1.ebuild 2360
MD5 e4d03e59a965a67c151afeee7e25b521 groff-1.18.1-r2.ebuild 2929
diff --git a/sys-apps/groff/files/digest-groff-1.18.1-r4 b/sys-apps/groff/files/digest-groff-1.18.1-r4
new file mode 100644
index 000000000000..09b570a44a72
--- /dev/null
+++ b/sys-apps/groff/files/digest-groff-1.18.1-r4
@@ -0,0 +1,2 @@
+MD5 4c7a1b478d230696f14743772f31639f groff-1.18.1.tar.gz 2250463
+MD5 957fad244caa648fdf3d6395ca27aa2e groff_1.18.1-7.diff.gz 115348
diff --git a/sys-apps/groff/groff-1.18.1-r4.ebuild b/sys-apps/groff/groff-1.18.1-r4.ebuild
new file mode 100644
index 000000000000..44c356336cef
--- /dev/null
+++ b/sys-apps/groff/groff-1.18.1-r4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18.1-r4.ebuild,v 1.1 2004/01/06 15:54:59 agriffis Exp $
+
+IUSE="X cjk"
+
+inherit eutils flag-o-matic
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text formatter used for man pages"
+MB_PATCH="${P/-/_}-7"
+SRC_URI="ftp://groff.ffii.org/pub/groff/old/${P}.tar.gz
+ cjk? ( http://people.debian.org/~ukai/groff/${MB_PATCH}.diff.gz )"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+
+KEYWORDS="x86 amd64 ppc sparc alpha mips hppa arm ia64 ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ >=sys-apps/texinfo-4.0"
+
+PDEPEND=">=sys-apps/man-1.5k-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ "`use cjk`" ]; then
+ # multibyte patch contains no-color-segfault
+ epatch ${WORKDIR}/${MB_PATCH}.diff
+ epatch ${FILESDIR}/${MB_PATCH}-fix.patch
+ else
+ # Do not segfault if no color is defined in input, bug #14329
+ # <azarah@gentoo.org> (08 Feb 2003)
+ epatch ${FILESDIR}/${P}-no-color-segfault.patch
+ fi
+
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch ${FILESDIR}/groff-1.18-infoext.patch
+
+ # Do not generate example files that require us to
+ # depend on netpbm.
+ epatch ${FILESDIR}/groff-1.18-no-netpbm-depend.patch
+
+ # Make dashes the same as minus on the keyboard so that you
+ # can search for it. Fixes #17580 and #16108
+ # Thanks to James Cloos <cloos@jhcloos.com>
+ epatch ${FILESDIR}/${PN}-man-UTF-8.diff
+
+ # Fix syntax error in pic2graph. Closes #32300.
+ sed -i -e "s:groffpic_opts=\"-U\":groffpic_opts=\"-U\";;:" contrib/pic2graph/pic2graph.sh
+}
+
+src_compile() {
+ local myconf=""
+
+ # Fix problems with not finding g++
+ [ -z "${CC}" ] && export CC="gcc"
+ [ -z "${CXX}" ] && export CXX="g++"
+
+ case ${ARCH} in
+ alpha)
+ # -Os causes segfaults, -O is probably a fine replacement
+ # (fixes bug 36008, 06 Jan 2004 agriffis)
+ replace-flags -Os -O
+ ;;
+ hppa)
+ # -march=2.0 makes groff unable to finish the compile process
+ export CFLAGS="${CFLAGS/-march=2.0/}"
+ export CXXFLAGS="${CXXFLAGS/-march=2.0/}"
+ ;;
+ esac
+
+ myconf="${myconf} `use_enable cjk multibyte`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=\${inforoot} \
+ ${myconf} || die
+
+ # parallel build doesn't work
+ emake -j1 || die
+
+ # Only build X stuff if we have X installed, but do
+ # not depend on it, else we get circular deps.
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ xmkmf || die
+ make depend all || die
+ fi
+}
+
+src_install() {
+ dodir /usr /usr/share/doc/${PF}/{examples,html}
+ make prefix=${D}/usr \
+ manroot=${D}/usr/share/man \
+ inforoot=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ make DESTDIR=${D} \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ install \
+ install.man || die
+ fi
+
+ #the following links are required for xman
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+ dosym soelim /usr/bin/zsoelim
+
+ cd ${S}
+ dodoc BUG-REPORT COPYING ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}
+