summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-06 07:20:16 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-06 07:20:16 +0000
commit21996738a8a701efdc32bb2bc137183e176214d3 (patch)
tree7684029ee000384a931270e954bdda25a565ae84 /sys-apps
parentnet-im/gajim: Version Bump (diff)
downloadgentoo-2-21996738a8a701efdc32bb2bc137183e176214d3.tar.gz
gentoo-2-21996738a8a701efdc32bb2bc137183e176214d3.tar.bz2
gentoo-2-21996738a8a701efdc32bb2bc137183e176214d3.zip
Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/toybox/ChangeLog7
-rw-r--r--sys-apps/toybox/toybox-0.5.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-apps/toybox/ChangeLog b/sys-apps/toybox/ChangeLog
index cb5eabe0c9a2..227ecd68fd7b 100644
--- a/sys-apps/toybox/ChangeLog
+++ b/sys-apps/toybox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/toybox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.4 2014/08/29 02:34:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.5 2014/10/06 07:20:16 patrick Exp $
+
+*toybox-0.5.0 (06 Oct 2014)
+
+ 06 Oct 2014; Patrick Lauer <patrick@gentoo.org> +toybox-0.5.0.ebuild:
+ Bump
*toybox-0.4.9-r1 (29 Aug 2014)
diff --git a/sys-apps/toybox/toybox-0.5.0.ebuild b/sys-apps/toybox/toybox-0.5.0.ebuild
new file mode 100644
index 000000000000..6338a8ca5e5c
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/toybox-0.5.0.ebuild,v 1.1 2014/10/06 07:20:16 patrick Exp $
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+# makefile is stupid
+RESTRICT="test"
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="http://landley.net/code/toybox/"
+SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.bz2"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_prepare() {
+ sed -i -e 's/LOCALE/LC_ALL/' scripts/make.sh || die
+ restore_config .config
+ export CC="$(tc-getCC)"
+ export HOSTCC="$(tc-getCC)"
+}
+
+src_configure() {
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ ewarn "Could not locate user configfile, so we will save a default one"
+ emake defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ emake toybox_unstripped V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin toybox_unstripped toybox
+}