summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-10 23:42:39 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-10 23:42:39 +0000
commit32642ebe34897e34a1222fe4c9cc5e4e06dbc12f (patch)
treebdd3cdc94cda70350a8e5b69270ccb88c255d5fb /sys-apps
parentAdd modular X dependencies (bug #124177). (diff)
downloadgentoo-2-32642ebe34897e34a1222fe4c9cc5e4e06dbc12f.tar.gz
gentoo-2-32642ebe34897e34a1222fe4c9cc5e4e06dbc12f.tar.bz2
gentoo-2-32642ebe34897e34a1222fe4c9cc5e4e06dbc12f.zip
Fix building with glibc-2.4 and newer.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-1.1.0.ebuild3
-rw-r--r--sys-apps/busybox/files/1.1.0/glibc.patch21
3 files changed, 28 insertions, 2 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index c56a24d42ff2..b2f08dcde4e5 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.76 2006/02/18 06:16:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.77 2006/03/10 23:42:39 vapier Exp $
+
+ 10 Mar 2006; Mike Frysinger <vapier@gentoo.org> +files/1.1.0/glibc.patch,
+ busybox-1.1.0.ebuild:
+ Fix building with glibc-2.4 and newer.
18 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+files/1.1.0/ppc64-insmod.patch, busybox-1.1.0.ebuild:
diff --git a/sys-apps/busybox/busybox-1.1.0.ebuild b/sys-apps/busybox/busybox-1.1.0.ebuild
index 1bce392526d3..9428a7eda69a 100644
--- a/sys-apps/busybox/busybox-1.1.0.ebuild
+++ b/sys-apps/busybox/busybox-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.0.ebuild,v 1.4 2006/03/10 23:25:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.0.ebuild,v 1.5 2006/03/10 23:42:39 vapier Exp $
inherit eutils
@@ -58,6 +58,7 @@ src_unpack() {
# patches go here!
epatch "${FILESDIR}"/1.1.0/bb.patch
epatch "${FILESDIR}"/1.1.0/ppc64-insmod.patch
+ epatch "${FILESDIR}"/1.1.0/glibc.patch
# we'll let portage do the stripping
sed -i \
diff --git a/sys-apps/busybox/files/1.1.0/glibc.patch b/sys-apps/busybox/files/1.1.0/glibc.patch
new file mode 100644
index 000000000000..9025265a65d2
--- /dev/null
+++ b/sys-apps/busybox/files/1.1.0/glibc.patch
@@ -0,0 +1,21 @@
+Index: networking/ping6.c
+===================================================================
+--- networking/ping6.c (revision 14514)
++++ networking/ping6.c (working copy)
+@@ -236,6 +236,16 @@
+ }
+ }
+
++/* libc defines have changed around on us, whee ! */
++#ifndef ICMP6_MEMBERSHIP_QUERY
++# define ICMP6_MEMBERSHIP_QUERY MLD_LISTENER_QUERY
++#endif
++#ifndef ICMP6_MEMBERSHIP_REPORT
++# define ICMP6_MEMBERSHIP_REPORT MLD_LISTENER_REPORT
++#endif
++#ifndef ICMP6_MEMBERSHIP_REDUCTION
++# define ICMP6_MEMBERSHIP_REDUCTION MLD_LISTENER_REDUCTION
++#endif
+ static char *icmp6_type_name (int id)
+ {
+ switch (id) {