summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-06-08 19:38:42 +0000
committerMike Frysinger <vapier@gentoo.org>2009-06-08 19:38:42 +0000
commit36f6d05ebd2872e32eeb5c3c8023d19a9f5261e7 (patch)
tree580e7bd8828cde393a2b6adfe35c4c81ae7bdb18 /sys-apps
parentVersion bump. Cleanup (diff)
downloadgentoo-2-36f6d05ebd2872e32eeb5c3c8023d19a9f5261e7.tar.gz
gentoo-2-36f6d05ebd2872e32eeb5c3c8023d19a9f5261e7.tar.bz2
gentoo-2-36f6d05ebd2872e32eeb5c3c8023d19a9f5261e7.zip
Fix latent LIBDIR references #273224 by Peter Alfredsen.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/ChangeLog6
-rw-r--r--sys-apps/openrc/openrc-0.4.3-r2.ebuild6
-rw-r--r--sys-apps/openrc/openrc-0.4.3-r3.ebuild6
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild6
4 files changed, 17 insertions, 7 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index c7a678bb7f8f..6e4b17050cdf 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.72 2009/06/08 12:29:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.73 2009/06/08 19:38:42 vapier Exp $
+
+ 08 Jun 2009; Mike Frysinger <vapier@gentoo.org> openrc-0.4.3-r2.ebuild,
+ openrc-0.4.3-r3.ebuild, openrc-9999.ebuild:
+ Fix latent LIBDIR references #273224 by Peter Alfredsen.
*openrc-0.4.3-r3 (08 Jun 2009)
diff --git a/sys-apps/openrc/openrc-0.4.3-r2.ebuild b/sys-apps/openrc/openrc-0.4.3-r2.ebuild
index b7910128c94b..27d1f734f0d4 100644
--- a/sys-apps/openrc/openrc-0.4.3-r2.ebuild
+++ b/sys-apps/openrc/openrc-0.4.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.4.3-r2.ebuild,v 1.2 2009/05/09 20:27:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.4.3-r2.ebuild,v 1.3 2009/06/08 19:38:42 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -125,7 +125,7 @@ add_boot_init_mit_config() {
}
pkg_preinst() {
- local f
+ local f LIBDIR=$(get_libdir)
# default net script is just comments, so no point in biting people
# in the ass by accident
@@ -276,6 +276,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ local LIBDIR=$(get_libdir)
+
# Remove old baselayout links
rm -f "${ROOT}"/etc/runlevels/boot/{check{fs,root},rmnologin}
diff --git a/sys-apps/openrc/openrc-0.4.3-r3.ebuild b/sys-apps/openrc/openrc-0.4.3-r3.ebuild
index 0bd70e58f052..f168f306c218 100644
--- a/sys-apps/openrc/openrc-0.4.3-r3.ebuild
+++ b/sys-apps/openrc/openrc-0.4.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.4.3-r3.ebuild,v 1.1 2009/06/08 12:29:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.4.3-r3.ebuild,v 1.2 2009/06/08 19:38:42 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -128,7 +128,7 @@ add_boot_init_mit_config() {
}
pkg_preinst() {
- local f
+ local f LIBDIR=$(get_libdir)
# default net script is just comments, so no point in biting people
# in the ass by accident
@@ -279,6 +279,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ local LIBDIR=$(get_libdir)
+
# Remove old baselayout links
rm -f "${ROOT}"/etc/runlevels/boot/{check{fs,root},rmnologin}
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 717927d68171..38de5f507bfb 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.48 2009/06/08 12:27:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.49 2009/06/08 19:38:42 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -125,7 +125,7 @@ add_boot_init_mit_config() {
}
pkg_preinst() {
- local f
+ local f LIBDIR=$(get_libdir)
# default net script is just comments, so no point in biting people
# in the ass by accident
@@ -276,6 +276,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ local LIBDIR=$(get_libdir)
+
# Remove old baselayout links
rm -f "${ROOT}"/etc/runlevels/boot/{check{fs,root},rmnologin}