summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-12-20 23:53:58 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-12-20 23:53:58 +0000
commit4f4c4ea558e66b07a60f87dccc30ee58c6827a70 (patch)
tree621cc7e162a5134435e646695c98f285a90104b8 /sys-apps
parentfix curl include - bug #75104 (Manifest recommit) (diff)
downloadgentoo-2-4f4c4ea558e66b07a60f87dccc30ee58c6827a70.tar.gz
gentoo-2-4f4c4ea558e66b07a60f87dccc30ee58c6827a70.tar.bz2
gentoo-2-4f4c4ea558e66b07a60f87dccc30ee58c6827a70.zip
New version
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/parted/ChangeLog7
-rw-r--r--sys-apps/parted/files/digest-parted-1.6.182
-rw-r--r--sys-apps/parted/parted-1.6.18.ebuild49
3 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 6fc78d8aa615..b5a6bcbacb08 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for sys-apps/parted
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.60 2004/12/16 20:15:13 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.61 2004/12/20 23:53:58 lu_zero Exp $
16 Dec 2004; Chris Gianelloni <wolf31o2@gentoo.org> metadata.xml:
Changing ownership to livecd herd.
+*parted-1.6.18 (21 Dec 2004)
+
+ 21 Dec 2004; Luca Barbato <lu_zero@gentoo.org> +parted-1.6.18.ebuild:
+ New version, amiga partitions supported by upstream
+
13 Dec 2004; Mike Frysinger <vapier@gentoo.org> parted-1.6.15.ebuild:
Clean up and push into stable.
diff --git a/sys-apps/parted/files/digest-parted-1.6.18 b/sys-apps/parted/files/digest-parted-1.6.18
new file mode 100644
index 000000000000..98595395fc33
--- /dev/null
+++ b/sys-apps/parted/files/digest-parted-1.6.18
@@ -0,0 +1,2 @@
+MD5 8986cc05ac21707785046b13bfbc9d38 parted-1.6.18.tar.gz 1416775
+MD5 1ddf2713c7d63bb0b02611e19b100af7 parted-1.6.18-gentoo.tar.bz2 23213
diff --git a/sys-apps/parted/parted-1.6.18.ebuild b/sys-apps/parted/parted-1.6.18.ebuild
new file mode 100644
index 000000000000..84223af14269
--- /dev/null
+++ b/sys-apps/parted/parted-1.6.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.18.ebuild,v 1.1 2004/12/20 23:53:58 lu_zero Exp $
+
+inherit eutils
+
+DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
+HOMEPAGE="http://www.gnu.org/software/parted"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${PF}-gentoo.tar.bz2
+ mirror://gentoo/${P}.tar.gz
+ http://dev.gentoo.org/~lu_zero/distfiles/${PF}-gentoo.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="nls static readline debug"
+
+DEPEND=">=sys-fs/e2fsprogs-1.27
+ >=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ readline? ( >=sys-libs/readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/patches
+ aclocal || die "aclocal failed"
+ libtoolize --copy --force || die "libtoolize failed"
+ automake || die "automake failed"
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable static all-static) \
+ --disable-Werror \
+ ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS TODO
+ dodoc doc/{API,FAQ,FAT,USER.jp}
+}