summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-05-13 08:51:56 +0000
committerMichał Górny <mgorny@gentoo.org>2013-05-13 08:51:56 +0000
commit5b07424a764829a8e810fc2837f7578f6e81df12 (patch)
treeb84a90a68928a84e81c1343f3932f5e5f41cfc4b /sys-apps
parentRemove old versions. (diff)
downloadgentoo-2-5b07424a764829a8e810fc2837f7578f6e81df12.tar.gz
gentoo-2-5b07424a764829a8e810fc2837f7578f6e81df12.tar.bz2
gentoo-2-5b07424a764829a8e810fc2837f7578f6e81df12.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog7
-rw-r--r--sys-apps/systemd/systemd-204.ebuild287
2 files changed, 293 insertions, 1 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 94f16d84bf00..98d29bad016f 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.134 2013/05/08 17:56:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.135 2013/05/13 08:51:56 mgorny Exp $
+
+*systemd-204 (13 May 2013)
+
+ 13 May 2013; Michał Górny <mgorny@gentoo.org> +systemd-204.ebuild:
+ Version bump.
*systemd-203-r1 (08 May 2013)
diff --git a/sys-apps/systemd/systemd-204.ebuild b/sys-apps/systemd/systemd-204.ebuild
new file mode 100644
index 000000000000..3e65329b4f29
--- /dev/null
+++ b/sys-apps/systemd/systemd-204.ebuild
@@ -0,0 +1,287 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-204.ebuild,v 1.1 2013/05/13 08:51:56 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+PYTHON_COMPAT=( python2_7 )
+inherit autotools-utils linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="acl audit cryptsetup doc +firmware-loader gcrypt gudev http introspection
+ keymap +kmod lzma openrc pam policykit python qrcode selinux static-libs
+ tcpd test vanilla xattr"
+
+MINKV="2.6.39"
+
+COMMON_DEPEND=">=sys-apps/dbus-1.6.8-r1
+ >=sys-apps/util-linux-2.20
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ audit? ( >=sys-process/audit-2 )
+ cryptsetup? ( >=sys-fs/cryptsetup-1.4.2 )
+ gcrypt? ( >=dev-libs/libgcrypt-1.4.5 )
+ gudev? ( >=dev-libs/glib-2 )
+ http? ( net-libs/libmicrohttpd )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+ kmod? ( >=sys-apps/kmod-12 )
+ lzma? ( app-arch/xz-utils )
+ pam? ( virtual/pam )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? ( media-gfx/qrencode )
+ selinux? ( sys-libs/libselinux )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xattr? ( sys-apps/attr )"
+
+# baselayout-2.2 has /run
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/baselayout-2.2
+ openrc? ( >=sys-fs/udev-init-scripts-25 )
+ policykit? ( sys-auth/polkit )
+ || (
+ >=sys-apps/util-linux-2.22
+ <sys-apps/sysvinit-2.88-r4
+ )
+ !sys-auth/nss-myhostname
+ !<sys-libs/glibc-2.10
+ !sys-fs/udev"
+
+PDEPEND=">=sys-apps/hwids-20130326.1[udev]"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gperf
+ >=dev-util/intltool-0.50
+ >=sys-devel/gcc-4.6
+ >=sys-kernel/linux-headers-${MINKV}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~AUTOFS4_FS ~BLK_DEV_BSG ~CGROUPS ~DEVTMPFS
+ ~FANOTIFY ~HOTPLUG ~INOTIFY_USER ~IPV6 ~NET ~PROC_FS ~SIGNALFD
+ ~SYSFS ~!IDE ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
+# ~!FW_LOADER_USER_HELPER"
+
+ # read null-terminated argv[0] from PID 1
+ # and see which path to systemd was used (if any)
+ local init_path
+ IFS= read -r -d '' init_path < /proc/1/cmdline
+ if [[ ${init_path} == */bin/systemd ]]; then
+ eerror "You are using a compatibility symlink to run systemd. The symlink"
+ eerror "has been removed. Please update your bootloader to use:"
+ eerror
+ eerror " init=/usr/lib/systemd/systemd"
+ eerror
+ eerror "and reboot your system. We are sorry for the inconvenience."
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ die "Compatibility symlink used to boot systemd."
+ fi
+ fi
+
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4
+ || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
+ then
+ eerror "systemd requires at least gcc 4.6 to build. Please switch the active"
+ eerror "gcc version using gcc-config."
+ die "systemd requires at least gcc 4.6"
+ fi
+ fi
+
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ if kernel_is -lt ${MINKV//./ }; then
+ ewarn "Kernel version at least ${MINKV} required"
+ fi
+
+ if ! use firmware-loader && kernel_is -lt 3 8; then
+ ewarn "You seem to be using kernel older than 3.8. Those kernel versions"
+ ewarn "require systemd with USE=firmware-loader to support loading"
+ ewarn "firmware. Missing this flag may cause some hardware not to work."
+ fi
+
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --with-pamlibdir=$(getpam_mod_dir)
+ # avoid bash-completion dep, default is stupid
+ --with-bashcompletiondir=/usr/share/bash-completion
+ # make sure we get /bin:/sbin in $PATH
+ --enable-split-usr
+ # disable sysv compatibility
+ --with-sysvinit-path=
+ --with-sysvrcnd-path=
+ # no deps
+ --enable-efi
+ --enable-ima
+ # optional components/dependencies
+ $(use_enable acl)
+ $(use_enable audit)
+ $(use_enable cryptsetup libcryptsetup)
+ $(use_enable doc gtk-doc)
+ $(use_enable gcrypt)
+ $(use_enable gudev)
+ $(use_enable http microhttpd)
+ $(use_enable introspection)
+ $(use_enable keymap)
+ $(use_enable kmod)
+ $(use_enable lzma xz)
+ $(use_enable pam)
+ $(use_enable policykit polkit)
+ $(use_with python)
+ $(use python && echo PYTHON_CONFIG=/usr/bin/python-config-${EPYTHON#python})
+ $(use_enable qrcode qrencode)
+ $(use_enable selinux)
+ $(use_enable tcpd tcpwrap)
+ $(use_enable test tests)
+ $(use_enable xattr)
+
+ # not supported (avoid automagic deps in the future)
+ --disable-chkconfig
+
+ # hardcode a few paths to spare some deps
+ QUOTAON=/usr/sbin/quotaon
+ QUOTACHECK=/usr/sbin/quotacheck
+ )
+
+ # Keep using the one where the rules were installed.
+ MY_UDEVDIR=$(get_udevdir)
+
+ if use firmware-loader; then
+ myeconfargs+=(
+ --with-firmware-path="/lib/firmware/updates:/lib/firmware"
+ )
+ fi
+
+ # Work around bug 463846.
+ tc-export CC
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile \
+ udevlibexecdir="${MY_UDEVDIR}"
+}
+
+src_install() {
+ autotools-utils_src_install -j1 \
+ udevlibexecdir="${MY_UDEVDIR}" \
+ dist_udevhwdb_DATA=
+
+ # keep udev working without initramfs, for openrc compat
+ dodir /bin /sbin
+ mv "${D}"/usr/lib/systemd/systemd-udevd "${D}"/sbin/udevd || die
+ mv "${D}"/usr/bin/udevadm "${D}"/bin/udevadm || die
+ dosym ../../../sbin/udevd /usr/lib/systemd/systemd-udevd
+ dosym ../../bin/udevadm /usr/bin/udevadm
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions
+ newins shell-completion/systemd-zsh-completion.zsh "_${PN}"
+
+ # compat for init= use
+ dosym ../usr/lib/systemd/systemd /bin/systemd
+ dosym ../lib/systemd/systemd /usr/bin/systemd
+ # rsyslog.service depends on it...
+ dosym ../usr/bin/systemctl /bin/systemctl
+
+ # we just keep sysvinit tools, so no need for the mans
+ rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
+ || die
+ rm "${D}"/usr/share/man/man1/init.1 || die
+
+ if ! use vanilla; then
+ # Create /run/lock as required by new baselay/OpenRC compat.
+ systemd_dotmpfilesd "${FILESDIR}"/gentoo-run.conf
+
+ # Add mount-rules for /var/lock and /var/run, bug #433607
+ systemd_dounit "${FILESDIR}"/var-{lock,run}.mount
+ systemd_enable_service sysinit.target var-lock.mount
+ systemd_enable_service sysinit.target var-run.mount
+ fi
+
+ # Disable storing coredumps in journald, bug #433457
+ mv "${D}"/usr/lib/sysctl.d/50-coredump.conf{,.disabled} || die
+
+ # Preserve empty dirs in /etc & /var, bug #437008
+ keepdir /etc/binfmt.d /etc/modules-load.d /etc/tmpfiles.d \
+ /etc/systemd/ntp-units.d /etc/systemd/user /var/lib/systemd
+
+ # Check whether we won't break user's system.
+ local x
+ for x in /bin/systemd /usr/bin/systemd \
+ /usr/bin/udevadm /usr/lib/systemd/systemd-udevd
+ do
+ [[ -x ${D}${x} ]] || die "${x} symlink broken, aborting."
+ done
+}
+
+optfeature() {
+ local i desc=${1} text
+ shift
+
+ text=" [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
+ shift
+
+ for i; do
+ elog "${text}"
+ text="& [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
+ done
+ elog "${text} (${desc})"
+}
+
+pkg_postinst() {
+ # for udev rules
+ enewgroup dialout
+
+ enewgroup systemd-journal
+ if use http; then
+ enewgroup systemd-journal-gateway
+ enewuser systemd-journal-gateway -1 -1 -1 systemd-journal-gateway
+ fi
+ systemd_update_catalog
+
+ # Keep this here in case the database format changes so it gets updated
+ # when required. Despite that this file is owned by sys-apps/hwids.
+ if has_version "sys-apps/hwids[udev]"; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
+
+ if [[ ! -L "${ROOT}"/etc/mtab ]]; then
+ ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
+ ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
+ ewarn "require that specific feature, please call:"
+ ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ ewarn
+ fi
+
+ elog "To get additional features, a number of optional runtime dependencies may"
+ elog "be installed:"
+ optfeature 'for GTK+ systemadm UI and gnome-ask-password-agent' \
+ 'sys-apps/systemd-ui'
+}
+
+pkg_prerm() {
+ # If removing systemd completely, remove the catalog database.
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ rm -f -v "${EROOT}"/var/lib/systemd/catalog/database
+ fi
+}