summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-09 07:52:37 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-09 07:52:37 +0000
commit5ce74b6e4a952576a6602425129f53f459421222 (patch)
treef3cd8f2854290ee17d6150ef026355cfb5d4fdd3 /sys-apps
parentVersion bump #245990 by Arfrever Frehtes Taifersar Arahesis. (diff)
downloadgentoo-2-5ce74b6e4a952576a6602425129f53f459421222.tar.gz
gentoo-2-5ce74b6e4a952576a6602425129f53f459421222.tar.bz2
gentoo-2-5ce74b6e4a952576a6602425129f53f459421222.zip
Rewrite multilib handling and apply parallel build fix by Jose Luis Rivero #190051 by David Pykee.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog8
-rw-r--r--sys-apps/sandbox/files/sandbox-1.2.20_alpha2-parallel.patch12
-rw-r--r--sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild63
3 files changed, 32 insertions, 51 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index b0223aa0e567..750318bfc82c 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.90 2008/11/09 07:26:17 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.91 2008/11/09 07:52:36 vapier Exp $
+
+ 09 Nov 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/sandbox-1.2.20_alpha2-parallel.patch,
+ sandbox-1.2.20_alpha2-r1.ebuild:
+ Rewrite multilib handling and apply parallel build fix by Jose Luis Rivero
+ #190051 by David Pykee.
09 Nov 2008; Harald van Dijk <truedfx@gentoo.org>
sandbox-1.2.18.1-r3.ebuild, sandbox-1.2.20_alpha2-r1.ebuild:
diff --git a/sys-apps/sandbox/files/sandbox-1.2.20_alpha2-parallel.patch b/sys-apps/sandbox/files/sandbox-1.2.20_alpha2-parallel.patch
new file mode 100644
index 000000000000..cbf769fc4e1b
--- /dev/null
+++ b/sys-apps/sandbox/files/sandbox-1.2.20_alpha2-parallel.patch
@@ -0,0 +1,12 @@
+http://bugs.gentooorg/190051
+
+--- libsandbox/Makefile.in
++++ libsandbox/Makefile.in
+@@ -517,6 +517,7 @@
+
+
+ libsandbox.c: libsandbox.map symbols.h
++wrappers.c: symbols.h
+
+ libsandbox.map: $(SYMBOLS_FILE) $(GEN_VERSION_MAP_SCRIPT)
+ @echo "Generating $@"; \
diff --git a/sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild b/sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild
index 85a82c6ee0bd..6d21a11a8d71 100644
--- a/sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild
+++ b/sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild,v 1.2 2008/11/09 07:26:17 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.20_alpha2-r1.ebuild,v 1.3 2008/11/09 07:52:36 vapier Exp $
#
# don't monkey with this ebuild unless contacting portage devs.
@@ -32,19 +32,6 @@ DEPEND=""
EMULTILIB_PKG="true"
-setup_multilib() {
- if use amd64 && has_m32 && [[ ${CONF_MULTILIBDIR} == "lib32" ]]; then
- export DEFAULT_ABI="amd64"
- export MULTILIB_ABIS="x86 amd64"
- export CFLAGS_amd64=${CFLAGS_amd64:-"-m64"}
- export CFLAGS_x86=${CFLAGS_x86-"-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"}
- export CHOST_amd64="x86_64-pc-linux-gnu"
- export CHOST_x86="i686-pc-linux-gnu"
- export LIBDIR_amd64=${LIBDIR_amd64-${CONF_LIBDIR}}
- export LIBDIR_x86=${LIBDIR_x86-${CONF_MULTILIBDIR}}
- fi
-}
-
src_unpack() {
unpack ${A}
@@ -57,25 +44,12 @@ src_unpack() {
sed -i -e 's/&> libctest.log/>libctest.log 2>\&1/g' configure || die "sed failed" #236868
cd "${S}/libsandbox"
- epatch "${FILESDIR}/${PN}-1.2.18.1-open-cloexec.patch"
-}
-
-abi_fail_check() {
- local ABI=$1
- if [[ ${ABI} == "x86" ]] ; then
- echo
- eerror "Building failed for ABI=x86!. This usually means a broken"
- eerror "multilib setup. Please fix that before filling a bugreport"
- eerror "against sandbox."
- echo
- fi
+ epatch "${FILESDIR}"/${PN}-1.2.18.1-open-cloexec.patch
+ epatch "${FILESDIR}"/${P}-parallel.patch #190051
}
src_compile() {
local myconf
- local iscross=0
-
- setup_multilib
filter-lfs-flags #90228
@@ -84,41 +58,30 @@ src_compile() {
ewarn "If configure fails with a 'cannot run C compiled programs' error, try this:"
ewarn "FEATURES=-sandbox emerge sandbox"
- [[ -n ${CBUILD} && ${CBUILD} != ${CHOST} ]] && iscross=1
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ mkdir "${WORKDIR}/build-${ABI}"
+ cd "${WORKDIR}/build-${ABI}"
- OABI=${ABI}
- OCHOST=${CHOST}
- for ABI in $(get_install_abis); do
- mkdir "${WORKDIR}/build-${ABI}-${OCHOST}"
- cd "${WORKDIR}/build-${ABI}-${OCHOST}"
+ multilib_toolchain_setup ${ABI}
# Needed for older broken portage versions (bug #109036)
has_version '<sys-apps/portage-2.0.51.22' && \
unset EXTRA_ECONF
- export ABI
- export CHOST=$(get_abi_CHOST)
- [[ ${iscross} == 0 ]] && export CBUILD=${CHOST}
-
einfo "Configuring sandbox for ABI=${ABI}..."
ECONF_SOURCE="../${MY_P}/" \
- econf --libdir="/usr/$(get_libdir)" ${myconf}
+ econf ${myconf} || die
einfo "Building sandbox for ABI=${ABI}..."
- emake || {
- abi_fail_check "${ABI}"
- die "emake failed for ${ABI}"
- }
+ emake || die
done
ABI=${OABI}
- CHOST=${OCHOST}
}
src_install() {
- setup_multilib
-
- OABI=${ABI}
- for ABI in $(get_install_abis); do
- cd "${WORKDIR}/build-${ABI}-${CHOST}"
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
einfo "Installing sandbox for ABI=${ABI}..."
emake DESTDIR="${D}" install || die "make install failed for ${ABI}"
done