summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2011-06-24 19:51:26 +0000
committerBrian Harring <ferringb@gentoo.org>2011-06-24 19:51:26 +0000
commit5f7608337ec43e9d5816b9d2787f123e95e2ecef (patch)
treef29196e227ea0a5a9a337ae8508fc65751ebb96f /sys-apps
parentDropped ~xf86-fbsd wrt #372885 (diff)
downloadgentoo-2-5f7608337ec43e9d5816b9d2787f123e95e2ecef.tar.gz
gentoo-2-5f7608337ec43e9d5816b9d2787f123e95e2ecef.tar.bz2
gentoo-2-5f7608337ec43e9d5816b9d2787f123e95e2ecef.zip
fix user profiles from /etc/portage/profiles in 0.6.5; reported by mgorny
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pkgcore/ChangeLog9
-rw-r--r--sys-apps/pkgcore/files/0.6.5-fix-screwup-in-incrementals-removal.patch28
-rw-r--r--sys-apps/pkgcore/pkgcore-0.6.5-r1.ebuild81
3 files changed, 117 insertions, 1 deletions
diff --git a/sys-apps/pkgcore/ChangeLog b/sys-apps/pkgcore/ChangeLog
index 74efe1a5ba2b..6bbbfe28bb14 100644
--- a/sys-apps/pkgcore/ChangeLog
+++ b/sys-apps/pkgcore/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pkgcore
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/ChangeLog,v 1.115 2011/06/24 19:38:57 ferringb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/ChangeLog,v 1.116 2011/06/24 19:51:26 ferringb Exp $
+
+*pkgcore-0.6.5-r1 (24 Jun 2011)
+
+ 24 Jun 2011; Brian Harring <ferringb@gentoo.org>
+ +files/0.6.5-fix-screwup-in-incrementals-removal.patch,
+ +pkgcore-0.6.5-r1.ebuild:
+ fix a screwup reported by mgorny for users w/ /etc/portage/profiles
24 Jun 2011; Brian Harring <ferringb@gentoo.org> pkgcore-0.6.5.ebuild:
update snakeoil deps to 0.4.1; missed in the commit.
diff --git a/sys-apps/pkgcore/files/0.6.5-fix-screwup-in-incrementals-removal.patch b/sys-apps/pkgcore/files/0.6.5-fix-screwup-in-incrementals-removal.patch
new file mode 100644
index 000000000000..e1e890ac9d20
--- /dev/null
+++ b/sys-apps/pkgcore/files/0.6.5-fix-screwup-in-incrementals-removal.patch
@@ -0,0 +1,28 @@
+From 6ada9442149d881271afcf8560db4a1b74a5eeaf Mon Sep 17 00:00:00 2001
+From: Brian Harring <ferringb@gmail.com>
+Date: Fri, 24 Jun 2011 12:46:38 -0700
+Subject: [PATCH] fix screwup in incrementals removal
+
+---
+ pkgcore/ebuild/profiles.py | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pkgcore/ebuild/profiles.py b/pkgcore/ebuild/profiles.py
+index 1fa91c6..ba7f251 100644
+--- a/pkgcore/ebuild/profiles.py
++++ b/pkgcore/ebuild/profiles.py
+@@ -451,9 +451,9 @@ class UserProfile(OnDiskProfile):
+ typename='profile')
+
+ def __init__(self, user_path, parent_path, parent_profile,
+- incrementals=const.incrementals, load_profiles_base=False):
++ load_profiles_base=False):
+ OnDiskProfile.__init__(self, parent_path, parent_profile,
+- incrementals, load_profiles_base)
++ load_profiles_base)
+ self.node = UserProfileNode(user_path, pjoin(parent_path, parent_profile))
+
+
+--
+1.7.5.3
+
diff --git a/sys-apps/pkgcore/pkgcore-0.6.5-r1.ebuild b/sys-apps/pkgcore/pkgcore-0.6.5-r1.ebuild
new file mode 100644
index 000000000000..ebbf25294540
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.6.5-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pkgcore/pkgcore-0.6.5-r1.ebuild,v 1.1 2011/06/24 19:51:26 ferringb Exp $
+
+EAPI="3"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit eutils distutils
+
+DESCRIPTION="pkgcore package manager"
+HOMEPAGE="http://www.pkgcore.org"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-python/snakeoil-0.4.1
+ dev-python/pyparsing
+ || ( >=dev-lang/python-2.5 dev-python/pycrypto )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/docutils-0.4 )"
+
+DOCS="AUTHORS NEWS"
+
+pkg_setup() {
+ # disable snakeoil 2to3 caching...
+ unset PY2TO3_CACHEDIR
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/0.6.5-fix-screwup-in-incrementals-removal.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ ./build_docs.py || die "doc building failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc dev-notes
+ doman man/*.1
+ fi
+
+ dodoc doc/*.rst man/*.rst
+ docinto dev-notes
+ dodoc dev-notes/*.rst
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ pplugincache
+
+ if [[ -d "${ROOT}etc/pkgcore/plugins" ]]; then
+ elog "You still have an /etc/pkgcore/plugins from pkgcore 0.1."
+ elog "It is unused by pkgcore >= 0.2, remove it now."
+ die "remove /etc/pkgcore/plugins from pkgcore 0.1"
+ fi
+
+ # This is left behind by pkgcore 0.2.
+ rm -f "${ROOT}"$(python_get_sitedir)/pkgcore/plugins/plugincache
+}
+
+pkg_postrm() {
+ # Careful not to remove this on up/downgrades.
+ local sitep="${ROOT}"$(python_get_sitedir)/site-packages
+ if [[ -e "${sitep}/pkgcore/plugins/plugincache2" ]] &&
+ ! [[ -e "${sitep}/pkgcore/plugin.py" ]]; then
+ rm "${sitep}/pkgcore/plugins/plugincache2"
+ fi
+ distutils_pkg_postrm
+}