summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-10 12:04:30 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-10 12:04:30 +0000
commit6818c6fc7668e4559e33927a1b39fac643d9a016 (patch)
tree7ab5073a6fd6c354ad2ed6383e9bc4bdfa7b1974 /sys-apps
parentStable for ppc64, wrt bug #442314 (diff)
downloadgentoo-2-6818c6fc7668e4559e33927a1b39fac643d9a016.tar.gz
gentoo-2-6818c6fc7668e4559e33927a1b39fac643d9a016.tar.bz2
gentoo-2-6818c6fc7668e4559e33927a1b39fac643d9a016.zip
Version bump.
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/ChangeLog7
-rw-r--r--sys-apps/pv/pv-1.4.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index 1a3f2d0f6889..781301316770 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pv
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.44 2012/11/12 13:21:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.45 2012/12/10 12:04:30 jer Exp $
+
+*pv-1.4.0 (10 Dec 2012)
+
+ 10 Dec 2012; Jeroen Roovers <jer@gentoo.org> +pv-1.4.0.ebuild:
+ Version bump.
*pv-1.3.9 (12 Nov 2012)
diff --git a/sys-apps/pv/pv-1.4.0.ebuild b/sys-apps/pv/pv-1.4.0.ebuild
new file mode 100644
index 000000000000..c2e2015ad5a5
--- /dev/null
+++ b/sys-apps/pv/pv-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.4.0.ebuild,v 1.1 2012/12/10 12:04:30 jer Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+
+IUSE="nls"
+PV_LINGUAS="de fr pl pt"
+for lingua in ${PV_LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+
+DOCS=( README doc/NEWS doc/TODO )
+
+src_configure() {
+ local lingua
+ for lingua in ${PV_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake LD="$(tc-getLD)"
+}