summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-18 03:37:18 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-18 03:37:18 +0000
commit69f719989ce8c956d87c647c0cd39822231d0067 (patch)
treefac62a60b71df52ff4f2c63ce5e592de1da33264 /sys-apps
parentadded prefix keywords (diff)
downloadgentoo-2-69f719989ce8c956d87c647c0cd39822231d0067.tar.gz
gentoo-2-69f719989ce8c956d87c647c0cd39822231d0067.tar.bz2
gentoo-2-69f719989ce8c956d87c647c0cd39822231d0067.zip
Disable some options that pointlessly bloat code, and add USE=systemd
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-1.20.2.ebuild5
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild5
-rw-r--r--sys-apps/busybox/metadata.xml1
4 files changed, 14 insertions, 3 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index cbaaa71c5428..3fc73db2f7da 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.325 2012/09/15 18:24:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.326 2012/09/18 03:37:18 vapier Exp $
+
+ 18 Sep 2012; Mike Frysinger <vapier@gentoo.org> busybox-1.20.2.ebuild,
+ busybox-9999.ebuild, metadata.xml:
+ Disable some options that pointlessly bloat code, and add USE=systemd
15 Sep 2012; Raúl Porcel <armin76@gentoo.org> busybox-1.20.2.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #431948
diff --git a/sys-apps/busybox/busybox-1.20.2.ebuild b/sys-apps/busybox/busybox-1.20.2.ebuild
index 6f90fdd78848..17066da721b5 100644
--- a/sys-apps/busybox/busybox-1.20.2.ebuild
+++ b/sys-apps/busybox/busybox-1.20.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.20.2.ebuild,v 1.7 2012/09/15 18:24:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.20.2.ebuild,v 1.8 2012/09/18 03:37:18 vapier Exp $
EAPI="4"
inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
@@ -133,7 +133,9 @@ src_configure() {
busybox_config_option n FEATURE_SUID_CONFIG
busybox_config_option n BUILD_AT_ONCE
busybox_config_option n BUILD_LIBBUSYBOX
+ busybox_config_option n FEATURE_CLEAN_UP
busybox_config_option n MONOTONIC_SYSCALL
+ busybox_config_option n USE_PORTABLE_CODE
busybox_config_option n WERROR
# If these are not set and we are using a uclibc/busybox setup
@@ -155,6 +157,7 @@ src_configure() {
&& busybox_config_option n PAM \
|| busybox_config_option pam PAM
busybox_config_option static STATIC
+ busybox_config_option systemd FEATURE_SYSTEMD
busybox_config_option math FEATURE_AWK_LIBM
# all the debug options are compiler related, so punt them
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index c68342d28b22..b8d442b531a9 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.4 2012/05/26 00:07:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-9999.ebuild,v 1.5 2012/09/18 03:37:18 vapier Exp $
EAPI="4"
inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
@@ -132,7 +132,9 @@ src_configure() {
busybox_config_option n FEATURE_SUID_CONFIG
busybox_config_option n BUILD_AT_ONCE
busybox_config_option n BUILD_LIBBUSYBOX
+ busybox_config_option n FEATURE_CLEAN_UP
busybox_config_option n MONOTONIC_SYSCALL
+ busybox_config_option n USE_PORTABLE_CODE
busybox_config_option n WERROR
# If these are not set and we are using a uclibc/busybox setup
@@ -154,6 +156,7 @@ src_configure() {
&& busybox_config_option n PAM \
|| busybox_config_option pam PAM
busybox_config_option static STATIC
+ busybox_config_option systemd FEATURE_SYSTEMD
busybox_config_option math FEATURE_AWK_LIBM
# all the debug options are compiler related, so punt them
diff --git a/sys-apps/busybox/metadata.xml b/sys-apps/busybox/metadata.xml
index 196769e2e376..db1a236ae87d 100644
--- a/sys-apps/busybox/metadata.xml
+++ b/sys-apps/busybox/metadata.xml
@@ -7,5 +7,6 @@
<flag name="math">Enable math support in gawk (requires libm)</flag>
<flag name="mdev">Create the appropriate symlink in /sbin and install mdev.conf and support files</flag>
<flag name="sep-usr">Support a separate /usr without needing an initramfs by booting with init=/ginit</flag>
+<flag name="systemd">Support systemd</flag>
</use>
</pkgmetadata>