summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-04-14 05:12:06 +0000
committerJeroen Roovers <jer@gentoo.org>2015-04-14 05:12:06 +0000
commit70bc90b060f34afb4d132828b42cfa68d0874c29 (patch)
tree20e5f07c85df516331879461df3f61e840c47cce /sys-apps
parentStable for HPPA (bug #546184). (diff)
downloadgentoo-2-70bc90b060f34afb4d132828b42cfa68d0874c29.tar.gz
gentoo-2-70bc90b060f34afb4d132828b42cfa68d0874c29.tar.bz2
gentoo-2-70bc90b060f34afb4d132828b42cfa68d0874c29.zip
Add a warning about kernel requirements with the --remote option (bug #526538 by Andrew Miller).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/ChangeLog8
-rw-r--r--sys-apps/pv/pv-1.6.0-r1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index 707d6743da48..e0272904820f 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pv
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.107 2015/03/16 06:09:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.108 2015/04/14 05:12:06 jer Exp $
+
+*pv-1.6.0-r1 (14 Apr 2015)
+
+ 14 Apr 2015; Jeroen Roovers <jer@gentoo.org> +pv-1.6.0-r1.ebuild:
+ Add a warning about kernel requirements with the --remote option (bug #526538
+ by Andrew Miller).
*pv-1.6.0 (16 Mar 2015)
diff --git a/sys-apps/pv/pv-1.6.0-r1.ebuild b/sys-apps/pv/pv-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..75850c33f227
--- /dev/null
+++ b/sys-apps/pv/pv-1.6.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.6.0-r1.ebuild,v 1.1 2015/04/14 05:12:06 jer Exp $
+
+EAPI=5
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PV_LINGUAS=( de fr pl pt )
+IUSE+=" ${PV_LINGUAS[@]/#/linguas_}"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+}
+
+src_configure() {
+ tc-export AR
+ local lingua
+ for lingua in ${PV_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable debug debugging) $(use_enable nls)
+}
+
+src_test() {
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ default
+}