summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-01 01:16:46 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-01 01:16:46 +0000
commit71761f2401e2ce474692f256a056bd770a70ba85 (patch)
treeaf98099769c28b33ea9cb0663bc1eb756f0bad58 /sys-apps
parentstop using this file; it is too confusing with arch.list ... if your repoman ... (diff)
downloadgentoo-2-71761f2401e2ce474692f256a056bd770a70ba85.tar.gz
gentoo-2-71761f2401e2ce474692f256a056bd770a70ba85.tar.bz2
gentoo-2-71761f2401e2ce474692f256a056bd770a70ba85.zip
ver bump #60396
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog8
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.081
-rw-r--r--sys-apps/microcode-ctl/files/microcode_ctl.conf.d5
-rw-r--r--sys-apps/microcode-ctl/files/microcode_ctl.rc14
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.08.ebuild45
5 files changed, 72 insertions, 1 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index 489fdb896549..e8bc6ede0477 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-ctl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.7 2004/06/24 22:16:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.8 2004/09/01 01:16:46 vapier Exp $
+
+*microcode-ctl-1.08 (31 Aug 2004)
+
+ 31 Aug 2004; Mike Frysinger <vapier@gentoo.org> +files/microcode_ctl.conf.d,
+ +files/microcode_ctl.rc, +microcode-ctl-1.08.ebuild:
+ Version bump and init.d scripts #60396 by Michael Cramer.
*microcode-ctl-1.07-r1 (05 Jun 2004)
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.08 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.08
new file mode 100644
index 000000000000..4f8e7ce8e56e
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.08
@@ -0,0 +1 @@
+MD5 b0cb86263c136b5bf7a44c723cb6996e microcode_ctl-1.08.tar.gz 171306
diff --git a/sys-apps/microcode-ctl/files/microcode_ctl.conf.d b/sys-apps/microcode-ctl/files/microcode_ctl.conf.d
new file mode 100644
index 000000000000..4bfbe2f40733
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/microcode_ctl.conf.d
@@ -0,0 +1,5 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/files/microcode_ctl.conf.d,v 1.1 2004/09/01 01:16:46 vapier Exp $
+
+MICROCODE_DEV="/dev/cpu/microcode"
diff --git a/sys-apps/microcode-ctl/files/microcode_ctl.rc b/sys-apps/microcode-ctl/files/microcode_ctl.rc
new file mode 100644
index 000000000000..cac4fc58b9ea
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/microcode_ctl.rc
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/files/microcode_ctl.rc,v 1.1 2004/09/01 01:16:46 vapier Exp $
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Updating microcode"
+ /usr/sbin/microcode_ctl -iqu -d ${MICROCODE_DEV}
+ eend $? "Failed to update microcode via '${MICROCODE_DEV}'"
+}
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.08.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.08.ebuild
new file mode 100644
index 000000000000..1fd306c030ee
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.08.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.08.ebuild,v 1.1 2004/09/01 01:16:46 vapier Exp $
+
+inherit gcc
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/os-headers"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake \
+ CC="$(gcc-getCC)" \
+ CFLAGS="${CFLAGS} -I${ROOT}/usr/include" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ insinto /etc
+ newins intel-ia32microcode-27July2004.txt microcode.dat
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/microcode_ctl.rc microcode_ctl
+ insinto /etc/conf.d ; newexe ${FILESDIR}/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}