summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-06-04 19:22:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-06-04 19:22:28 +0000
commit83d93c891a52d8d489f637ae74ce886b3098a075 (patch)
treefe1b8675b4545ba1d1d6ef78921c6d7676f92ffd /sys-apps
parentVersion bump, drop old (diff)
downloadgentoo-2-83d93c891a52d8d489f637ae74ce886b3098a075.tar.gz
gentoo-2-83d93c891a52d8d489f637ae74ce886b3098a075.tar.bz2
gentoo-2-83d93c891a52d8d489f637ae74ce886b3098a075.zip
Version bump to make use of the new series of c++-gtk-utils >= 2.2.0
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mount-gtk/ChangeLog8
-rw-r--r--sys-apps/mount-gtk/mount-gtk-1.4.2.ebuild36
2 files changed, 42 insertions, 2 deletions
diff --git a/sys-apps/mount-gtk/ChangeLog b/sys-apps/mount-gtk/ChangeLog
index ca777e1f2728..3329a508ada1 100644
--- a/sys-apps/mount-gtk/ChangeLog
+++ b/sys-apps/mount-gtk/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-apps/mount-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mount-gtk/ChangeLog,v 1.1 2013/05/11 17:38:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mount-gtk/ChangeLog,v 1.2 2013/06/04 19:22:28 ssuominen Exp $
+
+*mount-gtk-1.4.2 (04 Jun 2013)
+
+ 04 Jun 2013; Samuli Suominen <ssuominen@gentoo.org> +mount-gtk-1.4.2.ebuild:
+ Version bump to make use of the new series of c++-gtk-utils >= 2.2.0
*mount-gtk-1.4.1 (11 May 2013)
11 May 2013; Samuli Suominen <ssuominen@gentoo.org> +mount-gtk-1.4.1.ebuild:
Initial commit.
-
diff --git a/sys-apps/mount-gtk/mount-gtk-1.4.2.ebuild b/sys-apps/mount-gtk/mount-gtk-1.4.2.ebuild
new file mode 100644
index 000000000000..9b7f781aa961
--- /dev/null
+++ b/sys-apps/mount-gtk/mount-gtk-1.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mount-gtk/mount-gtk-1.4.2.ebuild,v 1.1 2013/06/04 19:22:28 ssuominen Exp $
+
+EAPI=5
+inherit autotools flag-o-matic
+
+DESCRIPTION="GTK+ based UDisks2 frontend"
+HOMEPAGE="http://mount-gtk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.28
+ sys-fs/udisks:2
+ x11-libs/c++-gtk-utils:0
+ x11-libs/libX11
+ x11-libs/libnotify:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS BUGS ChangeLog )
+
+src_prepare() {
+ sed -i -e 's:AC_CONFIG_HEADER:&S:' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -fexceptions -frtti -fsigned-char -fno-check-new -pthread -std=c++11
+# unset CXXFLAGS
+ econf --docdir=/usr/share/doc/${PF}
+}