summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-03-18 11:38:38 +0000
committerWout Mertens <wmertens@gentoo.org>2003-03-18 11:38:38 +0000
commit950fe51fcf71ec1b4a72c49f25d20f83a3cbddb6 (patch)
treea2b552c318bca86df8641b9b7234a7c4786f161a /sys-apps
parentRemoved old ebuilds. Added sparc-sources-2.4.20-r5. (diff)
downloadgentoo-2-950fe51fcf71ec1b4a72c49f25d20f83a3cbddb6.tar.gz
gentoo-2-950fe51fcf71ec1b4a72c49f25d20f83a3cbddb6.tar.bz2
gentoo-2-950fe51fcf71ec1b4a72c49f25d20f83a3cbddb6.zip
version bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lufs/ChangeLog11
-rw-r--r--sys-apps/lufs/files/digest-lufs-0.9.41
-rw-r--r--sys-apps/lufs/files/lufs-0.9.3-init13
-rw-r--r--sys-apps/lufs/lufs-0.9.3.ebuild4
-rw-r--r--sys-apps/lufs/lufs-0.9.4.ebuild53
5 files changed, 73 insertions, 9 deletions
diff --git a/sys-apps/lufs/ChangeLog b/sys-apps/lufs/ChangeLog
index 731a45ad6b02..0ab32f8b920d 100644
--- a/sys-apps/lufs/ChangeLog
+++ b/sys-apps/lufs/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for sys-apps/lufs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lufs/ChangeLog,v 1.7 2003/03/18 10:44:41 wmertens Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lufs/ChangeLog,v 1.8 2003/03/18 11:38:38 wmertens Exp $
- 18 Mar 2003; Wout Mertens <wmertens@gentoo.org> lufs-0.9.3.ebuild
+*lufs-0.9.4 (18 Mar 2003)
+ 18 Mar 2003; Wout Mertens <wmertens@gentoo.org> lufs-0.9.4.ebuild :
+ Turns out there was a new upstream version, and the init script and
+ lufs user don't make sense any more because the daemon was rewritten.
+
+ 18 Mar 2003; Wout Mertens <wmertens@gentoo.org> lufs-0.9.3.ebuild :
Fixed typo in install, -init was missing from the init script. Didn't
bump revision since the people that have it running probably
figured that out by themselves.
-*lufs-0.9.31 (12 Feb 2003)
+*lufs-0.9.3 (12 Feb 2003)
12 Feb 2003; Luca Barbato <lu_zero@gentoo.org> lufs-0.9.3.ebuild
files/digest-lufs-0.9.3 lufs-0.9.3-init
diff --git a/sys-apps/lufs/files/digest-lufs-0.9.4 b/sys-apps/lufs/files/digest-lufs-0.9.4
new file mode 100644
index 000000000000..ecd7a6b2082e
--- /dev/null
+++ b/sys-apps/lufs/files/digest-lufs-0.9.4
@@ -0,0 +1 @@
+MD5 5965236d501468488442f3c87181e947 lufs-0.9.4.tar.gz 413150
diff --git a/sys-apps/lufs/files/lufs-0.9.3-init b/sys-apps/lufs/files/lufs-0.9.3-init
index 1723f880e796..011ae995693f 100644
--- a/sys-apps/lufs/files/lufs-0.9.3-init
+++ b/sys-apps/lufs/files/lufs-0.9.3-init
@@ -6,19 +6,22 @@
#
# processname: lufs
# chkconfig: - 91 91
+#
+# lufsd is started by the lufs user, and logs are kept in its homedir.
+#
depend () {
need localmount
}
start () {
- echo -n "Starting lufsd... "
+ ebegin "Starting lufsd"
su - lufs -c "lufsd -d 2>~/lufsd.err >~/lufsd.log"
- echo
+ eend $? "Error starting lufsd"
}
stop () {
- echo -n "Shutting down lufsd... "
- killall lufsd
- echo
+ ebegin "Stopping lufsd"
+ pkill lufsd
+ eend $? "Error stopping lufsd"
}
diff --git a/sys-apps/lufs/lufs-0.9.3.ebuild b/sys-apps/lufs/lufs-0.9.3.ebuild
index 02fc268bc231..947a8a910375 100644
--- a/sys-apps/lufs/lufs-0.9.3.ebuild
+++ b/sys-apps/lufs/lufs-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lufs/lufs-0.9.3.ebuild,v 1.3 2003/03/18 10:44:41 wmertens Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lufs/lufs-0.9.3.ebuild,v 1.4 2003/03/18 11:38:38 wmertens Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="User-mode filesystem implementation"
@@ -47,8 +47,10 @@ src_install () {
pkg_postinst() {
id lufs 2>/dev/null || useradd -g nobody -d /home/lufs -m -s /bin/sh -c "LUFS user" lufs
+ /usr/sbin/update-modules || return 0
}
pkg_postrm() {
+ /sbin/modprobe -r lufs
userdel lufs
}
diff --git a/sys-apps/lufs/lufs-0.9.4.ebuild b/sys-apps/lufs/lufs-0.9.4.ebuild
new file mode 100644
index 000000000000..5ecb6f7574ee
--- /dev/null
+++ b/sys-apps/lufs/lufs-0.9.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lufs/lufs-0.9.4.ebuild,v 1.1 2003/03/18 11:38:38 wmertens Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="User-mode filesystem implementation"
+SRC_URI="mirror://sourceforge/lufs/${P}.tar.gz"
+HOMEPAGE="http://lufs.sourceforge.net/lufs/"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+#RDEPEND
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lufsd
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-exec-hook//' Makefile.in.orig > Makefile.in || die
+
+ cd ${S}/util
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-exec-hook//' Makefile.in.orig > Makefile.in || die
+
+ cd ${S}/kernel/Linux/2.4
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-data-hook//' Makefile.in.orig > Makefile.in || die
+}
+
+src_install () {
+ dodoc AUTHORS COPYING ChangeLog Contributors INSTALL \
+ NEWS README THANKS TODO
+ dohtml docs/lufs.html
+ make DESTDIR=${D} install
+
+ dosym /usr/bin/auto.sshfs /etc/auto.sshfs
+ dosym /usr/bin/auto.ftpfs /etc/auto.ftpfs
+ dodir /sbin
+ dosym /usr/bin/lufsd /sbin/mount.lufs
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules
+ einfo If you want regular users to be able to mount lufs filesystems,
+ einfo you need to run the following command as root:
+ einfo \# chmod +s /usr/bin/lufsmnt /usr/bin/lufsumount
+}
+
+pkg_postrm() {
+ /sbin/modprobe -r lufs
+}