summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-25 06:57:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-25 06:57:37 +0000
commit99d91426d2c697e47c805b57f06cbc656a22a2f4 (patch)
treeebb5182ca2594513345072129219c4371d35359e /sys-apps
parentdev-lisp/cl-rfc2109 (diff)
downloadgentoo-2-99d91426d2c697e47c805b57f06cbc656a22a2f4.tar.gz
gentoo-2-99d91426d2c697e47c805b57f06cbc656a22a2f4.tar.bz2
gentoo-2-99d91426d2c697e47c805b57f06cbc656a22a2f4.zip
dont force glibc regex when using glibc-2.2.x
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/findutils-4.3.0.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/findutils/findutils-4.3.0.ebuild b/sys-apps/findutils/findutils-4.3.0.ebuild
index c40510ecf18a..1a38c38d6f22 100644
--- a/sys-apps/findutils/findutils-4.3.0.ebuild
+++ b/sys-apps/findutils/findutils-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.14 2006/08/19 14:19:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.15 2006/08/25 06:57:37 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -37,9 +37,9 @@ src_unpack() {
echo "#include_next <regex.h>" > gnulib/lib/regex.h
fi
- [[ ${ELIBC} == "NetBSD" ]] && epatch "${FILESDIR}/${P}-nbsd.patch"
+ [[ ${ELIBC} == "NetBSD" ]] && epatch "${FILESDIR}"/${P}-nbsd.patch
- epatch "${FILESDIR}/gnulib-openat-mode_t.patch"
+ epatch "${FILESDIR}"/gnulib-openat-mode_t.patch
}
src_compile() {
@@ -48,8 +48,11 @@ src_compile() {
local myconf
use userland_GNU || myconf=" --program-prefix=g"
- [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ if ([[ ${ELIBC} == "glibc" ]] && has_version '>=sys-libs/glibc-2.3') \
+ || [[ ${ELIBC} == "uclibc" ]]
+ then
myconf="${myconf} --without-included-regex"
+ fi
econf $(use_enable nls) ${myconf} || die "configure failed"
emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"