summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2005-06-19 22:07:03 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2005-06-19 22:07:03 +0000
commita93458863ab515f5c9bf489c86d39089cb2ac065 (patch)
treed8886346b549ec5d2cf6ff99f0b32c0d9cd1e7f9 /sys-apps
parentStable on ppc64. (diff)
downloadgentoo-2-a93458863ab515f5c9bf489c86d39089cb2ac065.tar.gz
gentoo-2-a93458863ab515f5c9bf489c86d39089cb2ac065.tar.bz2
gentoo-2-a93458863ab515f5c9bf489c86d39089cb2ac065.zip
Initial import of 855resolution package
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/855resolution/855resolution-0.4.ebuild33
-rw-r--r--sys-apps/855resolution/ChangeLog10
-rw-r--r--sys-apps/855resolution/Manifest6
-rw-r--r--sys-apps/855resolution/files/0.4/conf26
-rw-r--r--sys-apps/855resolution/files/0.4/init32
-rw-r--r--sys-apps/855resolution/files/digest-855resolution-0.41
-rw-r--r--sys-apps/855resolution/metadata.xml21
7 files changed, 129 insertions, 0 deletions
diff --git a/sys-apps/855resolution/855resolution-0.4.ebuild b/sys-apps/855resolution/855resolution-0.4.ebuild
new file mode 100644
index 000000000000..7aa5b0219f59
--- /dev/null
+++ b/sys-apps/855resolution/855resolution-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/855resolution/855resolution-0.4.ebuild,v 1.1 2005/06/19 22:07:03 fafhrd Exp $
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="Utility to patch VBIOS of Intel 855 / 865 / 915 chipsets."
+HOMEPAGE="http://perso.wanadoo.fr/apoirier"
+SRC_URI="http://perso.wanadoo.fr/apoirier/${P}.tgz"
+
+LICENSE="public-domain as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+#RDEPEND=""
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/sbin
+ doexe ${PN}
+
+ dodoc README.txt
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PV}/conf 855resolution
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PV}/init 855resolution
+}
diff --git a/sys-apps/855resolution/ChangeLog b/sys-apps/855resolution/ChangeLog
new file mode 100644
index 000000000000..f3b918498931
--- /dev/null
+++ b/sys-apps/855resolution/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/855resolution
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/855resolution/ChangeLog,v 1.1 2005/06/19 22:07:03 fafhrd Exp $
+
+ 19 Jun 2005; Armando Di Cianno <fafhrd@gentoo.org> ChangeLog:
+ Initial import of 855resolution package which patches the VBIOS of Intel
+ 815, 865, 915 chipsets so that one can insert a correct video mode entry
+ into the VBIOS; package suggestion and conf.d/init.d files by
+ Gard Spreeman <spreeman -| at |- stud.ntnu.no>
+
diff --git a/sys-apps/855resolution/Manifest b/sys-apps/855resolution/Manifest
new file mode 100644
index 000000000000..59d46e40b7ad
--- /dev/null
+++ b/sys-apps/855resolution/Manifest
@@ -0,0 +1,6 @@
+MD5 e14c6559476cbd13b1250c69791bb04b 855resolution-0.4.ebuild 659
+MD5 495ab43dbd9d2e091b192c1eef101361 ChangeLog 451
+MD5 749d1a615d9d995c9ce5f05a0b77b06b metadata.xml 720
+MD5 4e0085928cb8a40e48ea5c76f13a6776 files/digest-855resolution-0.4 64
+MD5 a0e1dfa404d0f001abcdf801923d376e files/0.4/conf 875
+MD5 836cf1504be8f859bf55ca7ba034db05 files/0.4/init 658
diff --git a/sys-apps/855resolution/files/0.4/conf b/sys-apps/855resolution/files/0.4/conf
new file mode 100644
index 000000000000..ac2c28da7e88
--- /dev/null
+++ b/sys-apps/855resolution/files/0.4/conf
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/855resolution/files/0.4/conf,v 1.1 2005/06/19 22:07:03 fafhrd Exp $
+
+# Config file for /etc/init.d/855resolution
+
+# Since 855resolution alters the video RAM of your 855 card, it must be run
+# on every boot.
+# In this file you set which modes are to be replaced with what by the init
+# script. The syntax should be self-explaining.
+# To find out which modes are available, use "855resolution -l".
+# Remember to add 855resolution to your default runlevel:
+# rc-update add 855resolution default
+
+# e.g's (it seems for most people 5c defaults to "1920x1440", which
+# usually isn't used, so the example uses that one
+replace[0]="5c"
+with[0]="1400 1050"
+#with[0]="1280 800"
+
+# Uncomment these if you want to replace more modes:
+#replace[1]="modenumber"
+#with[1]="width height"
+#replace[2]="modenumber"
+#with[2]="width height"
+
diff --git a/sys-apps/855resolution/files/0.4/init b/sys-apps/855resolution/files/0.4/init
new file mode 100644
index 000000000000..448a9c7b171a
--- /dev/null
+++ b/sys-apps/855resolution/files/0.4/init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/855resolution/files/0.4/init,v 1.1 2005/06/19 22:07:03 fafhrd Exp $
+
+depend() {
+ before xdm
+}
+
+checkconfig() {
+ if [ -z "${replace[0]}" ] || [ -z "${with[0]}" ]
+ then
+ eerror "You need to set at least one replace/with pair in /etc/conf.d/855resolution"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Running 855resolution to replace ${#replace[@]} mode(s)"
+ i=0; return=0; retval=0
+ for target in "${replace[@]}"
+ do
+ /usr/sbin/855resolution $target ${with[$i]} > /dev/null
+ retval=$?
+ if [ "$retval"!=0 ]; then return=$retval; fi
+ i=$(($i+1))
+ done
+ eend $return
+}
+
diff --git a/sys-apps/855resolution/files/digest-855resolution-0.4 b/sys-apps/855resolution/files/digest-855resolution-0.4
new file mode 100644
index 000000000000..ffb0c28e4d69
--- /dev/null
+++ b/sys-apps/855resolution/files/digest-855resolution-0.4
@@ -0,0 +1 @@
+MD5 12237e534def7dd3579a3e8b0a4b9351 855resolution-0.4.tgz 6740
diff --git a/sys-apps/855resolution/metadata.xml b/sys-apps/855resolution/metadata.xml
new file mode 100644
index 000000000000..89e6222f46fb
--- /dev/null
+++ b/sys-apps/855resolution/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>fafhrd@gentoo.org</email>
+</maintainer>
+<longdescription>
+Utility to patch VBIOS (video BIOS) of Intel 855, 865, 915 chipsets.
+
+This program is necessary to create and set video modes so that other
+ programs (like X) can detect the modes.
+
+855resolution is likely most useful to laptop owners with these
+chipsets, who need to set miscellaneous video modes like
+1400x1050 or 1280x800, and their VBIOS doesn't the mode in itself
+after boot time.
+
+Please consult the package's README.txt, or the homepage, for usage info.
+</longdescription>
+</pkgmetadata>