summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2005-08-08 17:03:52 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2005-08-08 17:03:52 +0000
commitac21c292f120918898a139ab2201521d7d4a4eb4 (patch)
treec2f372c9d144612f0bcf10327db20523c57c628c /sys-apps
parentForgot to remove the epatch thingy :S (diff)
downloadgentoo-2-ac21c292f120918898a139ab2201521d7d4a4eb4.tar.gz
gentoo-2-ac21c292f120918898a139ab2201521d7d4a4eb4.tar.bz2
gentoo-2-ac21c292f120918898a139ab2201521d7d4a4eb4.zip
adding munmap patch (see bug #101694)
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/turbotail/ChangeLog8
-rw-r--r--sys-apps/turbotail/Manifest5
-rw-r--r--sys-apps/turbotail/files/digest-turbotail-0.2-r11
-rw-r--r--sys-apps/turbotail/files/turbotail-0.2-munmap.patch11
-rw-r--r--sys-apps/turbotail/turbotail-0.2-r1.ebuild32
5 files changed, 55 insertions, 2 deletions
diff --git a/sys-apps/turbotail/ChangeLog b/sys-apps/turbotail/ChangeLog
index 1b5b76ca5d24..fdfa87de0ffd 100644
--- a/sys-apps/turbotail/ChangeLog
+++ b/sys-apps/turbotail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/turbotail
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.2 2005/08/06 09:10:18 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.3 2005/08/08 17:03:52 sbriesen Exp $
+
+*turbotail-0.2-r1 (08 Aug 2005)
+
+ 08 Aug 2005; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/turbotail-0.2-munmap.patch, +turbotail-0.2-r1.ebuild:
+ adding munmap patch (see bug #101694)
06 Aug 2005; David Holm <dholm@gentoo.org> turbotail-0.2.ebuild:
Added to ~ppc.
diff --git a/sys-apps/turbotail/Manifest b/sys-apps/turbotail/Manifest
index 12bc9948dbb1..08fb7036a04d 100644
--- a/sys-apps/turbotail/Manifest
+++ b/sys-apps/turbotail/Manifest
@@ -1,4 +1,7 @@
+MD5 fd88470064409fe2d753b023dbfb58fa turbotail-0.2.ebuild 681
+MD5 7d1e4c56a8ecad1393c6cba486505022 turbotail-0.2-r1.ebuild 803
MD5 0b32a511659210704aefeca9f28922a5 ChangeLog 453
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 fd88470064409fe2d753b023dbfb58fa turbotail-0.2.ebuild 681
+MD5 92a0255cbb3e1575323119175be61a46 files/digest-turbotail-0.2-r1 60
+MD5 2eae56efaff3b112abc369cdcaf90b77 files/turbotail-0.2-munmap.patch 320
MD5 92a0255cbb3e1575323119175be61a46 files/digest-turbotail-0.2 60
diff --git a/sys-apps/turbotail/files/digest-turbotail-0.2-r1 b/sys-apps/turbotail/files/digest-turbotail-0.2-r1
new file mode 100644
index 000000000000..45c55b7c1488
--- /dev/null
+++ b/sys-apps/turbotail/files/digest-turbotail-0.2-r1
@@ -0,0 +1 @@
+MD5 24903c65622391e62f238218cfc5c2d7 turbotail-0.2.tgz 6411
diff --git a/sys-apps/turbotail/files/turbotail-0.2-munmap.patch b/sys-apps/turbotail/files/turbotail-0.2-munmap.patch
new file mode 100644
index 000000000000..39110d2a8d71
--- /dev/null
+++ b/sys-apps/turbotail/files/turbotail-0.2-munmap.patch
@@ -0,0 +1,11 @@
+--- turbotail.c.orig 2004-08-17 22:21:51.000000000 +0200
++++ turbotail.c 2005-08-08 04:18:09.000000000 +0200
+@@ -355,7 +355,7 @@
+ return -1;
+ }
+
+- if (munmap(mmap_addr, finfo.st_size) == -1)
++ if ((finfo.st_size > 0) && (munmap(mmap_addr, finfo.st_size) == -1))
+ {
+ error("munmap failed\n");
+ return -1;
diff --git a/sys-apps/turbotail/turbotail-0.2-r1.ebuild b/sys-apps/turbotail/turbotail-0.2-r1.ebuild
new file mode 100644
index 000000000000..6a0cacea78d2
--- /dev/null
+++ b/sys-apps/turbotail/turbotail-0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/turbotail-0.2-r1.ebuild,v 1.1 2005/08/08 17:03:52 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="drop-in replacement for 'tail' which uses the kernel DNOTIFY-api"
+HOMEPAGE="http://www.vanheusden.com/Linux/"
+SRC_URI="http://www.vanheusden.com/Linux/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # apply munmap patch (see bug #101694)
+ epatch "${FILESDIR}/${P}-munmap.patch"
+}
+
+src_compile() {
+ # enforce our CFLAGS
+ emake CFLAGS="-Wall ${CFLAGS} -DVERSION=\"${VERSION}\"" || die "emake failed"
+}
+
+src_install() {
+ dobin turbotail || die "install failed"
+ dodoc readme.txt
+}