summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-06 01:35:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-06 01:35:53 +0000
commitb54438ba87a51936950dc8a6394710a54cbde997 (patch)
tree745bd5f37445279712c0ef51ba4b2430fa548a56 /sys-apps
parentMeant to be ~x86 (diff)
downloadgentoo-2-b54438ba87a51936950dc8a6394710a54cbde997.tar.gz
gentoo-2-b54438ba87a51936950dc8a6394710a54cbde997.tar.bz2
gentoo-2-b54438ba87a51936950dc8a6394710a54cbde997.zip
Add switch capabilities #91182 by Ekatalog and BSD support #90847 by Diego Pettenò.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gawk/ChangeLog9
-rw-r--r--sys-apps/gawk/files/filefuncs/filefuncs.c3
-rw-r--r--sys-apps/gawk/gawk-3.1.4-r4.ebuild37
3 files changed, 29 insertions, 20 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 084f8ea35173..34d32ac0ab7b 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/gawk
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.53 2005/02/19 17:56:30 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.54 2005/05/06 01:35:53 vapier Exp $
+
+ 06 May 2005; Mike Frysinger <vapier@gentoo.org>
+ files/filefuncs/filefuncs.c, gawk-3.1.4-r4.ebuild:
+ Add switch capabilities #91182 by Ekatalog and BSD support #90847 by Diego
+ Pettenò.
*gawk-3.1.4-r4 (19 Feb 2005)
diff --git a/sys-apps/gawk/files/filefuncs/filefuncs.c b/sys-apps/gawk/files/filefuncs/filefuncs.c
index 97041eba58b2..4f3436cf0767 100644
--- a/sys-apps/gawk/files/filefuncs/filefuncs.c
+++ b/sys-apps/gawk/files/filefuncs/filefuncs.c
@@ -30,7 +30,7 @@
* Copyright 1999-2004 Gentoo Foundation
* Distributed under the terms of the GNU General Public License v2
* Author: Martin Schlemmer <azarah@gentoo.org>, Nov 2002
- * $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/filefuncs.c,v 1.2 2004/09/28 01:52:18 swegener Exp $
+ * $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/filefuncs.c,v 1.3 2005/05/06 01:35:53 vapier Exp $
*
* Extended with: do_symlink()
* do_unlink()
@@ -44,7 +44,6 @@
#include "awk.h"
#include <unistd.h>
-#include <sys/sysmacros.h>
/* do_chdir --- provide dynamically loaded chdir() builtin for gawk */
diff --git a/sys-apps/gawk/gawk-3.1.4-r4.ebuild b/sys-apps/gawk/gawk-3.1.4-r4.ebuild
index 400b930abb1e..b65b0bf60046 100644
--- a/sys-apps/gawk/gawk-3.1.4-r4.ebuild
+++ b/sys-apps/gawk/gawk-3.1.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.4-r4.ebuild,v 1.3 2005/02/21 10:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.4-r4.ebuild,v 1.4 2005/05/06 01:35:53 vapier Exp $
inherit eutils toolchain-funcs
@@ -15,8 +15,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="nls build xml"
-RDEPEND="virtual/libc
- xml? ( dev-libs/expat )"
+RDEPEND="xml? ( dev-libs/expat )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -35,7 +34,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-nextc.patch #fedora
epatch "${FILESDIR}"/${P}-uplow.patch #fedora
# support for dec compiler.
- [[ $(tc-getCC) == "ccc" ]] && epatch ${FILESDIR}/${PN}-3.1.2-dec-alpha-compiler.diff
+ [[ $(tc-getCC) == "ccc" ]] && epatch "${FILESDIR}"/${PN}-3.1.2-dec-alpha-compiler.diff
if use xml ; then
mkdir "${SXML}"
@@ -49,7 +48,11 @@ src_unpack() {
}
src_compile() {
- econf --bindir=/bin $(use_enable nls) || die
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ --enable-switch \
+ || die
emake || die "emake failed"
if use xml ; then
cd "${SXML}"
@@ -78,34 +81,34 @@ src_install() {
dodir /usr/bin
# In some rare cases, (p)gawk gets installed as (p)gawk- and not
- # (p)gawk-${PV} .. Also make sure that /bin/(p)gawk is a symlink
+ # (p)gawk-${PV} ... Also make sure that /bin/(p)gawk is a symlink
# to /bin/(p)gawk-${PV}.
- local x=
+ local binpath x
for x in gawk pgawk igawk ; do
- local binpath
[[ ${x} == "gawk" ]] \
&& binpath="/bin" \
|| binpath="/usr/bin"
if [[ -f ${D}/bin/${x} && ! -f ${D}/bin/${x}-${PV} ]] ; then
- mv -f ${D}/bin/${x} ${D}/${binpath}/${x}-${PV}
+ mv -f "${D}"/bin/${x} "${D}"/${binpath}/${x}-${PV}
elif [[ -f ${D}/bin/${x}- && ! -f ${D}/bin/${x}-${PV} ]] ; then
- mv -f ${D}/bin/${x}- ${D}/${binpath}/${x}-${PV}
+ mv -f "${D}"/bin/${x}- "${D}"/${binpath}/${x}-${PV}
elif [[ ${binpath} == "/usr/bin" && -f ${D}/bin/${x}-${PV} ]] ; then
- mv -f ${D}/bin/${x}-${PV} ${D}/${binpath}/${x}-${PV}
+ mv -f "${D}"/bin/${x}-${PV} "${D}"/${binpath}/${x}-${PV}
fi
- rm -f ${D}/bin/${x}
+ rm -f "${D}"/bin/${x}
dosym ${x}-${PV} ${binpath}/${x}
[[ ${binpath} == "/usr/bin" ]] && dosym /usr/bin/${x}-${PV} /bin/${x}
done
rm -f "${D}"/bin/awk
- dosym gawk-${PV} /bin/awk
- # Compat symlinks
dodir /usr/bin
- dosym /bin/gawk-${PV} /usr/bin/awk
+ # Compat symlinks
dosym /bin/gawk-${PV} /usr/bin/gawk
+ dosym gawk-${PV} /bin/awk
+ dosym /bin/gawk-${PV} /usr/bin/awk
+ [[ ${USERLAND} != "GNU" ]] && rm -f "${D}"/{,usr/}bin/awk{,-${PV}}
# Install headers
insinto /usr/include/awk
@@ -115,7 +118,9 @@ src_install() {
if ! use build ; then
cd "${S}"
- dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ rm -f "${D}"/usr/share/man/man1/pgawk.1
+ dosym gawk.1.gz /usr/share/man/man1/pgawk.1.gz
+ [[ ${USERLAND} == "GNU" ]] && dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README
docinto README_d
dodoc README_d/*