summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-20 08:59:36 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-20 08:59:36 +0000
commitbcdec5c61aec9dcd30c13077cf2cc0b7fcea95d4 (patch)
tree7620e2bb82c33c4d1153ab7f7ef352c443e75c98 /sys-apps
parentipv6 and CFLAGS update (diff)
downloadgentoo-2-bcdec5c61aec9dcd30c13077cf2cc0b7fcea95d4.tar.gz
gentoo-2-bcdec5c61aec9dcd30c13077cf2cc0b7fcea95d4.tar.bz2
gentoo-2-bcdec5c61aec9dcd30c13077cf2cc0b7fcea95d4.zip
new version
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/texinfo/ChangeLog7
-rw-r--r--sys-apps/texinfo/files/digest-texinfo-4.2b1
-rw-r--r--sys-apps/texinfo/texinfo-4.2b.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index b4ac22ab42e5..b1c92711b9ae 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/texinfo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.9 2002/08/01 19:33:53 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.10 2002/10/20 08:59:36 azarah Exp $
+
+*texinfo-4.2b (20 Oct 2002)
+
+ 20 Oct 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Update version.
*texinfo-4.2-r5 (8 Jul 2002)
diff --git a/sys-apps/texinfo/files/digest-texinfo-4.2b b/sys-apps/texinfo/files/digest-texinfo-4.2b
new file mode 100644
index 000000000000..b15dc59cc9f3
--- /dev/null
+++ b/sys-apps/texinfo/files/digest-texinfo-4.2b
@@ -0,0 +1 @@
+MD5 3fa4b7aab8e4d2d7df0a8c45fdd44fd3 texinfo-4.2b.tar.gz 1727679
diff --git a/sys-apps/texinfo/texinfo-4.2b.ebuild b/sys-apps/texinfo/texinfo-4.2b.ebuild
new file mode 100644
index 000000000000..ece572fa56fd
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.2b.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.2b.ebuild,v 1.1 2002/10/20 08:59:36 azarah Exp $
+
+IUSE="nls build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU info program and utilities"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/texinfo/${P}.tar.gz
+ ftp://alpha.gnu.org/pub/gnu/texinfo/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+RDEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/doc
+ # Get the texinfo info page to have a proper name of texinfo.info
+ cp texinfo.txi texinfo.txi.orig
+ sed -e 's:setfilename texinfo:setfilename texinfo.info:' \
+ texinfo.txi.orig > texinfo.txi
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:INFO_DEPS = texinfo:INFO_DEPS = texinfo.info:' \
+ -e 's:texinfo\::texinfo.info\::' \
+ Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+ local myconf=""
+ if [ -z "`use nls`" ] || [ -n "`use build`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ export WANT_AUTOMAKE_1_6=1
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ if [ "`use build`" ] ; then
+ dobin makeinfo/makeinfo util/{install-info,texi2dvi,texindex}
+ else
+ make DESTDIR=${D} \
+ infodir=/usr/share/info \
+ install || die
+
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkinfodir
+
+ if [ ! -f ${D}/usr/share/info/texinfo.info ] ; then
+ die "Could not install texinfo.info!!!"
+ fi
+
+ dodoc AUTHORS ChangeLog COPYING INTRODUCTION NEWS README TODO
+ docinto info
+ dodoc info/README
+ docinto makeinfo
+ dodoc makeinfo/README
+ fi
+}
+