summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2013-02-20 22:37:32 +0000
committerZac Medico <zmedico@gentoo.org>2013-02-20 22:37:32 +0000
commitc335560916605c555277165ea41f4492ba526eeb (patch)
tree9043e4e5d8d80530e2ae7c2198697de17e1b06fe /sys-apps
parentAdd ~arm and ~ppc (diff)
downloadgentoo-2-c335560916605c555277165ea41f4492ba526eeb.tar.gz
gentoo-2-c335560916605c555277165ea41f4492ba526eeb.tar.bz2
gentoo-2-c335560916605c555277165ea41f4492ba526eeb.zip
Fix for prefix and add ~arm-linux + ~x86-linux keywords.
(Portage version: 2.2.0_alpha163_p9/cvs/Linux i686, signed Manifest commit with key 0xFDE8EF85AE5719A3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog5
-rw-r--r--sys-apps/coreutils/coreutils-8.21.ebuild19
2 files changed, 14 insertions, 10 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 4931dd14e7f7..d0eff208ac1e 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.370 2013/02/18 21:45:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.371 2013/02/20 22:37:32 zmedico Exp $
+
+ 20 Feb 2013; Zac Medico <zmedico@gentoo.org> coreutils-8.21.ebuild:
+ Fix for prefix and add ~arm-linux + ~x86-linux keywords.
*coreutils-8.21 (18 Feb 2013)
diff --git a/sys-apps/coreutils/coreutils-8.21.ebuild b/sys-apps/coreutils/coreutils-8.21.ebuild
index f925e4dab836..ab0166173a36 100644
--- a/sys-apps/coreutils/coreutils-8.21.ebuild
+++ b/sys-apps/coreutils/coreutils-8.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-8.21.ebuild,v 1.1 2013/02/18 21:45:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-8.21.ebuild,v 1.2 2013/02/20 22:37:32 zmedico Exp $
EAPI="3"
@@ -19,7 +19,7 @@ SRC_URI="mirror://gnu-alpha/coreutils/${P}.tar.xz
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~arm-linux ~x86-linux"
IUSE="acl caps gmp nls selinux static userland_BSD vanilla xattr"
LIB_DEPEND="acl? ( sys-apps/acl[static-libs] )
@@ -109,7 +109,7 @@ src_test() {
for w in "$@" ; do
ww="${T}/mount-wrappers/${w}"
cat <<-EOF > "${ww}"
- #!/bin/sh
+ #!${EPREFIX}/bin/sh
exec env SANDBOX_WRITE="\${SANDBOX_WRITE}:/etc/mtab:/dev/loop" $(type -P $w) "\$@"
EOF
chmod a+rx "${ww}"
@@ -132,7 +132,7 @@ src_install() {
newins src/dircolors.hin DIR_COLORS || die
if [[ ${USERLAND} == "GNU" ]] ; then
- cd "${D}"/usr/bin
+ cd "${ED}"/usr/bin
dodir /bin
# move critical binaries into /bin (required by FHS)
local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
@@ -149,8 +149,9 @@ src_install() {
done
else
# For now, drop the man pages, collides with the ones of the system.
- rm -rf "${D}"/usr/share/man
+ rm -rf "${ED}"/usr/share/man
fi
+
}
pkg_postinst() {
@@ -159,15 +160,15 @@ pkg_postinst() {
ewarn " changes, such as: source /etc/profile"
# /bin/dircolors sometimes sticks around #224823
- if [ -e "${ROOT}/usr/bin/dircolors" ] && [ -e "${ROOT}/bin/dircolors" ] ; then
- if strings "${ROOT}/bin/dircolors" | grep -qs "GNU coreutils" ; then
+ if [ -e "${EROOT}/usr/bin/dircolors" ] && [ -e "${EROOT}/bin/dircolors" ] ; then
+ if strings "${EROOT}/bin/dircolors" | grep -qs "GNU coreutils" ; then
einfo "Deleting orphaned GNU /bin/dircolors for you"
- rm -f "${ROOT}/bin/dircolors"
+ rm -f "${EROOT}/bin/dircolors"
fi
fi
# Help out users using experimental filesystems
- if grep -qs btrfs "${ROOT}"/etc/fstab /proc/mounts ; then
+ if grep -qs btrfs "${EROOT}"/etc/fstab /proc/mounts ; then
case $(uname -r) in
2.6.[12][0-9]|2.6.3[0-7]*)
ewarn "You are running a system with a buggy btrfs driver."