summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-01-02 22:50:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-01-02 22:50:15 +0000
commitc8d87de35fc50e633086361fbde88d7ce0c0ad10 (patch)
tree47c7895067ca826dbdbe116c5e2229ded837c2a4 /sys-apps
parentpunt old ebuilds and files (diff)
downloadgentoo-2-c8d87de35fc50e633086361fbde88d7ce0c0ad10.tar.gz
gentoo-2-c8d87de35fc50e633086361fbde88d7ce0c0ad10.tar.bz2
gentoo-2-c8d87de35fc50e633086361fbde88d7ce0c0ad10.zip
Version bump
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gradm/ChangeLog10
-rw-r--r--sys-apps/gradm/files/gradm-2.2.1.201012301333.patch30
-rw-r--r--sys-apps/gradm/gradm-2.2.1.201012301333.ebuild55
3 files changed, 93 insertions, 2 deletions
diff --git a/sys-apps/gradm/ChangeLog b/sys-apps/gradm/ChangeLog
index 4b874d250b4c..9f01df028202 100644
--- a/sys-apps/gradm/ChangeLog
+++ b/sys-apps/gradm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gradm
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/ChangeLog,v 1.142 2010/12/21 14:14:41 blueness Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/ChangeLog,v 1.143 2011/01/02 22:50:15 blueness Exp $
+
+*gradm-2.2.1.201012301333 (02 Jan 2011)
+
+ 02 Jan 2011; Anthony G. Basile <blueness@gentoo.org>
+ +gradm-2.2.1.201012301333.ebuild, +files/gradm-2.2.1.201012301333.patch:
+ Version bump
21 Dec 2010; Anthony G. Basile <blueness@gentoo.org>
-gradm-2.1.14.201004061746.ebuild, -gradm-2.2.0.201009022049.ebuild,
diff --git a/sys-apps/gradm/files/gradm-2.2.1.201012301333.patch b/sys-apps/gradm/files/gradm-2.2.1.201012301333.patch
new file mode 100644
index 000000000000..b702e059b713
--- /dev/null
+++ b/sys-apps/gradm/files/gradm-2.2.1.201012301333.patch
@@ -0,0 +1,30 @@
+--- Makefile.orig 2010-08-13 21:39:07.000000000 -0400
++++ Makefile 2010-08-13 21:40:54.000000000 -0400
+@@ -18,16 +18,16 @@
+ BISON=/usr/bin/bison
+ #YACC := $(shell if [ -x $(BYACC) ]; then echo $(BYACC); else echo $(BISON); fi)
+ YACC=$(BISON)
+-MKNOD=/bin/mknod
++MKNOD=true
+ #for dietlibc
+ #CC=/usr/bin/diet /usr/bin/gcc
+ CC=/usr/bin/gcc
+ FIND=/usr/bin/find
+-STRIP=/usr/bin/strip
++STRIP=true
+ LIBS := $(shell if [ "`uname -m`" != "sparc64" ]; then echo "-lfl" ; else echo "" ; fi)
+ OPT_FLAGS := $(shell if [ "`uname -m`" != "sparc64" ] && [ "`uname -m`" != "x86_64" ]; then echo "-O2" ; else echo "-O2 -m64" ; fi)
+ CFLAGS := $(OPT_FLAGS) -Wcast-qual -DGRSEC_DIR=\"$(GRSEC_DIR)\" -D_LARGEFILE64_SOURCE
+-LDFLAGS=
++LDFLAGS+=
+ INSTALL = /usr/bin/install -c
+
+ # FHS
+@@ -134,6 +134,7 @@
+ $(MKNOD) -m 0622 $(DESTDIR)/dev/grsec c 1 13 ; \
+ fi \
+ fi
++ @mkdir -p $(DESTDIR)/etc/udev/rules.d
+ @if [ -d $(DESTDIR)/etc/udev/rules.d ] ; then \
+ echo "ACTION!=\"add|change\", GOTO=\"permissions_end\"" > $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
+ echo "KERNEL==\"grsec\", MODE=\"0622\"" >> $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
diff --git a/sys-apps/gradm/gradm-2.2.1.201012301333.ebuild b/sys-apps/gradm/gradm-2.2.1.201012301333.ebuild
new file mode 100644
index 000000000000..89c35d5a960f
--- /dev/null
+++ b/sys-apps/gradm/gradm-2.2.1.201012301333.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-2.2.1.201012301333.ebuild,v 1.1 2011/01/02 22:50:15 blueness Exp $
+
+EAPI=2
+
+inherit flag-o-matic toolchain-funcs versionator
+
+MY_PV="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Administrative interface for the grsecurity Role Based Access Control system"
+HOMEPAGE="http://www.grsecurity.net/"
+SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ pam? ( virtual/pam )
+ sys-apps/paxctl"
+
+S="${WORKDIR}/${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() {
+ local target
+ use pam || target="nopam"
+
+ emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR="${D}" || die "einstall failed"
+ fperms 711 /sbin/gradm
+}
+
+pkg_postinst() {
+ local UDEVADM="/sbin/udevadm"
+ if [[ -x ${UDEVADM} ]] ; then
+ $UDEVADM trigger --action=add --sysname-match=grsec
+ fi
+ einfo
+ ewarn
+ ewarn "Be sure to set a password with 'gradm -P' before enabling learning mode"
+ ewarn "This version of gradm is only supported with hardened-sources >= 2.6.32-r10"
+ ewarn
+ einfo
+}