summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-10-21 04:45:53 +0000
committerZack Welch <zwelch@gentoo.org>2002-10-21 04:45:53 +0000
commitd6624f486093a665bbd80eb2e4014e8ec3ada5c3 (patch)
treeff970f55000ea8a7328280c40e973ab72094b4e9 /sys-apps
parentoops in DEPEND (diff)
downloadgentoo-2-d6624f486093a665bbd80eb2e4014e8ec3ada5c3.tar.gz
gentoo-2-d6624f486093a665bbd80eb2e4014e8ec3ada5c3.tar.bz2
gentoo-2-d6624f486093a665bbd80eb2e4014e8ec3ada5c3.zip
Add new apcupsd-3.10.1 ebuild (bug 7778) (~'d for testing)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/apcupsd/ChangeLog15
-rw-r--r--sys-apps/apcupsd/apcupsd-3.10.1.ebuild77
-rw-r--r--sys-apps/apcupsd/files/digest-apcupsd-3.10.12
3 files changed, 92 insertions, 2 deletions
diff --git a/sys-apps/apcupsd/ChangeLog b/sys-apps/apcupsd/ChangeLog
index f7d6fb99937d..ef11e6efbb25 100644
--- a/sys-apps/apcupsd/ChangeLog
+++ b/sys-apps/apcupsd/ChangeLog
@@ -1,8 +1,19 @@
# ChangeLog for sys-apps/apcupsd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/ChangeLog,v 1.3 2002/08/12 18:20:57 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/ChangeLog,v 1.4 2002/10/21 04:45:53 zwelch Exp $
-*apcupsd-3.8.1 (1 Feb 2002)
+*apcupsd-3.10.1 (20 Oct 2002)
+
+ 20 Oct 2002; Zach Welch <zwelch@gentoo.org> :
+ New version incorporating changes made by Superlucidity Services, LLC, to
+ support Gentoo without additional patching.
+ First version (in portage) that supports USB UPSes, and the defaults for the
+ configuration file use these (as examples for serial are shown in comments).
+ This version also installs all the add ons for the package which were
+ previously disabeld. This includes multimon cgi support.
+ See bug 7778 for more information.
+
+*apcupsd-3.8.5 (14 Jul 2002)
14 Jul 2002; phoen][x <phoenix@gentoo.org> apcupsd-3.8.1.ebuild, files/digest-apcupsd-3.8.1 :
Bumped to new version.
diff --git a/sys-apps/apcupsd/apcupsd-3.10.1.ebuild b/sys-apps/apcupsd/apcupsd-3.10.1.ebuild
new file mode 100644
index 000000000000..88582bfcb8fe
--- /dev/null
+++ b/sys-apps/apcupsd/apcupsd-3.10.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apcupsd/apcupsd-3.10.1.ebuild,v 1.1 2002/10/21 04:45:53 zwelch Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown (*ALPHA*)"
+SRC_URI="ftp://ftp.apcupsd.com/pub/apcupsd/development/${P}.tar.gz \
+ ftp://ftp.apcupsd.com/pub/apcupsd/contrib/gd1.2.tar.gz"
+HOMEPAGE="http://www.sibbald.com/apcupsd/"
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/mta
+ sys-libs/ncurses"
+
+XPIDDIR=/var/run
+XLOGDIR=/var/log
+XLOCKDIR=/var/lock
+XSYSCONFDIR=/etc/apcupsd
+XPWRFAILDIR=${XSYSCONFDIR}
+
+src_unpack() {
+ unpack ${A}
+
+ cp -a ${WORKDIR}/gd1.2 ${S}/src/
+ cp -a ${S} ${S}-orig
+ ln -s /usr/portage/sys-apps/apcupsd/files ${WORKDIR}/files
+}
+
+src_compile() {
+ # --with-distname redundant for >=baselayout-1.8.4, but req'd for prev.
+ MAIL=/usr/sbin/sendmail ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/sbin \
+ --sysconfdir=${XSYSCONFDIR} \
+ --with-pwrfail-dir=${XPWRFAILDIR} \
+ --with-lock-dir=${XLOCKDIR} \
+ --with-pid-dir=${XPIDDIR} \
+ --with-log-dir=${XLOGDIR} \
+ --with-distname=gentoo \
+ --with-upstype=usb \
+ --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --with-net-port=6666 \
+ --with-nis-port=7000 \
+ --enable-usb \
+ --enable-net \
+ --enable-powerflute \
+ --enable-pthreads \
+ --with-css-dir=/home/httpd/apcupsd \
+ --with-cgi-bin=/home/httpd/apcupsd \
+ --enable-cgi \
+ || die
+ make || die
+}
+
+src_install () {
+ GEN2DD=${D}
+ make DESTDIR=${GEN2DD%*/} install
+
+ echo "Installing full documentation into /usr/share/doc/${P}..."
+ cd ${S}/doc
+ dodoc README.*
+ docinto developers_manual
+ dodoc developers_manual/*
+ docinto logo
+ dodoc logo/*
+ docinto manual
+ dodoc manual/*
+ docinto old_documents
+ dodoc old_documents/*
+ docinto vim
+ dodoc vim/*
+}
+
diff --git a/sys-apps/apcupsd/files/digest-apcupsd-3.10.1 b/sys-apps/apcupsd/files/digest-apcupsd-3.10.1
new file mode 100644
index 000000000000..dd73af393701
--- /dev/null
+++ b/sys-apps/apcupsd/files/digest-apcupsd-3.10.1
@@ -0,0 +1,2 @@
+MD5 6a0b94fde7383a200fd54fd4ab7d874c apcupsd-3.10.1.tar.gz 2516797
+MD5 d9a0ddf7918c93ca28fa5832a4af54d8 gd1.2.tar.gz 64595