summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-03-19 22:24:28 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-03-19 22:24:28 +0000
commitdae1184e69c3c686d553203e1f204599c6834516 (patch)
tree9964c996f53a51da06572eec075fd1ee9e336d4e /sys-apps
parentAdded sparc-sources-2.4.20-r6 (diff)
downloadgentoo-2-dae1184e69c3c686d553203e1f204599c6834516.tar.gz
gentoo-2-dae1184e69c3c686d553203e1f204599c6834516.tar.bz2
gentoo-2-dae1184e69c3c686d553203e1f204599c6834516.zip
corrected patch. closes #17801.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/ChangeLog8
-rw-r--r--sys-apps/man/files/digest-man-1.5l-r11
-rw-r--r--sys-apps/man/files/man-1.5l-redhat-patches.patch2
-rw-r--r--sys-apps/man/man-1.5l-r1.ebuild112
4 files changed, 121 insertions, 2 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index a6ceedc68d5b..c3b667d115bc 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.20 2003/03/18 20:38:20 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.21 2003/03/19 22:24:28 mholzer Exp $
+
+*man-1.5l-r1 (19 Mar 2003)
+
+ 19 Mar 2003; root <root@gentoo.org> man-1.5l-r1.ebuild,
+ files/man-1.5l-redhat-patches.patch:
+ corrected patch. closes #17801.
18 Mar 2003; Martin Schlemmer <azarah@gentoo.org> *-wrong-quotes.patch :
Fix issue where 'man -K' just cause a lot of 'grep errors', bug #16581.
diff --git a/sys-apps/man/files/digest-man-1.5l-r1 b/sys-apps/man/files/digest-man-1.5l-r1
new file mode 100644
index 000000000000..1d4a35da11da
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.5l-r1
@@ -0,0 +1 @@
+MD5 07fa5ab41c39afcd59cdef5139ef563b man-1.5l.tar.gz 218249
diff --git a/sys-apps/man/files/man-1.5l-redhat-patches.patch b/sys-apps/man/files/man-1.5l-redhat-patches.patch
index 1b0bb73ecb8a..7959ce7d1fb4 100644
--- a/sys-apps/man/files/man-1.5l-redhat-patches.patch
+++ b/sys-apps/man/files/man-1.5l-redhat-patches.patch
@@ -141,7 +141,7 @@ diff -Narup man-1.5k.orig/src/makewhatis.sh man-1.5k/src/makewhatis.sh
fi
done
-DEFCATPATH=$dc
-+DEFCATPATH=$dc;$DEFMANPATH
++DEFCATPATH=$dc:$DEFMANPATH
# In case /usr is read-only, make /usr/man/whatis (etc) a symlink to
# something like /var/cache/man/whatis.
diff --git a/sys-apps/man/man-1.5l-r1.ebuild b/sys-apps/man/man-1.5l-r1.ebuild
new file mode 100644
index 000000000000..9414230f9a32
--- /dev/null
+++ b/sys-apps/man/man-1.5l-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5l-r1.ebuild,v 1.1 2003/03/19 22:24:28 mholzer Exp $
+
+IUSE=""
+
+inherit eutils
+
+NV="${PV}"
+S="${WORKDIR}/${PN}-${NV}"
+DESCRIPTION="Standard commands to read man pages"
+SRC_URI="http://www.kernel.org/pub/linux/utils/man/man-${NV}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/man/"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="sys-apps/cronbase
+ >=sys-apps/groff-1.18"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa arm mips"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:/usr/lib/locale:$(prefix)/usr/lib/locale:g' \
+ -e 's!/usr/bin:/usr/ucb:!/usr/bin:!' \
+ configure.orig > configure
+
+ local x=""
+ for x in / src/ man2html/ msgs/
+ do
+ cd ${S}/${x}
+ cp Makefile.in Makefile.in.orig
+ sed -e '/inst.sh/d' \
+ -e '/^CC =/c\' \
+ -e "CC = gcc" \
+ -e '/^CFLAGS =/c\' \
+ -e "CFLAGS = ${CFLAGS}" \
+ Makefile.in.orig > Makefile.in
+ done
+
+ cd ${S}/gencat
+ cp Makefile Makefile.orig
+ sed -e "s:cc -o:gcc -o:" Makefile.orig > Makefile
+
+ cd ${S}
+ # Fix search order in man.conf so that system installed manpages
+ # will be found first ...
+ epatch ${FILESDIR}/${P}-search-order.patch
+
+ # For groff-1.18 or later we need to call nroff with '-c'
+ epatch ${FILESDIR}/${P}-groff-1.18.patch
+
+ # Fix wierd failing in rare cases
+ epatch ${FILESDIR}/${P}-wrong-quotes.patch
+
+ # Fix a crash when calling man with: man -k "foo bar" (bug #9761).
+ # <azarah@gentoo.org> (26 Dec 2002).
+ epatch ${FILESDIR}/${P}-util_c-segfault.patch
+
+ # Various fixes from Redhat
+ epatch ${FILESDIR}/${P}-redhat-patches.patch
+
+ # Do not print the 'man: No such file or directory' error if
+ # 'man -d' was called and the NLS catalogue was not found, as
+ # it confuses people, and be more informative ... (bug #6360)
+ # <azarah@gentoo.org> (26 Dec 2002).
+ epatch ${FILESDIR}/${P}-locale-debug-info.patch
+}
+
+src_compile() {
+ local myconf=""
+ use nls && myconf="+lang all"
+
+ ./configure -confdir=/etc \
+ +sgid +fhs \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/{bin,sbin}
+ cd ${S}
+ make PREFIX=${D} install || die
+
+ if [ -n "`use nls`" ]
+ then
+ cd ${S}/msgs
+ ./inst.sh ?? ${D}/usr/share/locale/%L/%N
+ fi
+
+ chmod 2555 ${D}/usr/bin/man
+ chown root.man ${D}/usr/bin/man
+
+ # Needed for makewhatis
+ keepdir /var/cache/man
+
+ insinto /etc
+ cd ${S}
+ doins src/man.conf
+
+ dodoc COPYING LSM README* TODO
+
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/makewhatis.cron
+}
+