summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-09-04 21:31:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-09-04 21:31:18 +0000
commite38d3410859e6e68b1693bc7330d7a999e04965f (patch)
tree02c15bd994b969a6fc511f3c290487f3fef4a369 /sys-apps
parentwhitespace (diff)
downloadgentoo-2-e38d3410859e6e68b1693bc7330d7a999e04965f.tar.gz
gentoo-2-e38d3410859e6e68b1693bc7330d7a999e04965f.tar.bz2
gentoo-2-e38d3410859e6e68b1693bc7330d7a999e04965f.zip
Added a patch from Ryan Hill <dirtyepic@gentoo.org> to fix the tests failing. Closing bug #191116.
(Portage version: 2.1.3.6)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/parted/ChangeLog7
-rw-r--r--sys-apps/parted/files/parted-1.8.8-t3100-test-success.patch19
-rw-r--r--sys-apps/parted/parted-1.8.8.ebuild8
3 files changed, 32 insertions, 2 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 75cb5105fdbb..3aedd67378ce 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/parted
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.119 2007/08/22 17:32:37 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.120 2007/09/04 21:31:18 wolf31o2 Exp $
+
+ 04 Sep 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/parted-1.8.8-t3100-test-success.patch, parted-1.8.8.ebuild:
+ Added a patch from Ryan Hill <dirtyepic@gentoo.org> to fix the tests
+ failing. Closing bug #191116.
22 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org> parted-1.8.8.ebuild:
Changing LICENSE.
diff --git a/sys-apps/parted/files/parted-1.8.8-t3100-test-success.patch b/sys-apps/parted/files/parted-1.8.8-t3100-test-success.patch
new file mode 100644
index 000000000000..5418ce0d2c1a
--- /dev/null
+++ b/sys-apps/parted/files/parted-1.8.8-t3100-test-success.patch
@@ -0,0 +1,19 @@
+diff -Naur parted-1.8.8-orig/tests/t3100-resize-ext2-partion.sh parted-1.8.8/tests/t3100-resize-ext2-partion.sh
+--- parted-1.8.8-orig/tests/t3100-resize-ext2-partion.sh 2007-08-09 12:47:57.000000000 -0600
++++ parted-1.8.8/tests/t3100-resize-ext2-partion.sh 2007-09-02 21:10:42.000000000 -0600
+@@ -44,13 +44,9 @@
+ 'parted -s $dev mkpartfs primary ext2 0 $ORIG_SIZE > out 2>&1'
+ test_expect_success 'check for empty output' '$compare out /dev/null'
+
+-# FIXME: this test currently fails with the diagnostic "error: block
+-# relocator should have relocated 64".
+-# Eventually, when this bug is fixed, change each of the following
+-# expected failures to "test_expect_success".
+-test_expect_failure \
++test_expect_success \
+ 'resize ext2 primary partition' \
+ 'parted -s $dev resize 1 0 $NEW_SIZE > out 2>&1'
+-test_expect_failure 'check for empty output' '$compare out /dev/null'
++test_expect_success 'check for empty output' '$compare out /dev/null'
+
+ test_done
diff --git a/sys-apps/parted/parted-1.8.8.ebuild b/sys-apps/parted/parted-1.8.8.ebuild
index 677d49fcc6da..fa6ad7c33763 100644
--- a/sys-apps/parted/parted-1.8.8.ebuild
+++ b/sys-apps/parted/parted-1.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.8.8.ebuild,v 1.2 2007/08/22 17:32:37 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.8.8.ebuild,v 1.3 2007/09/04 21:31:18 wolf31o2 Exp $
DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
HOMEPAGE="http://www.gnu.org/software/parted"
@@ -20,6 +20,12 @@ DEPEND=">=sys-fs/e2fsprogs-1.27
selinux? ( sys-libs/libselinux )
device-mapper? ( sys-fs/device-mapper )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-t3100-test-success.patch
+}
+
src_compile() {
econf \
$(use_with readline) \