summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-08-26 12:21:02 +0000
committerTom Gall <tgall@gentoo.org>2004-08-26 12:21:02 +0000
commite711284a818b744e657d56c216288db01df2295f (patch)
treeb30fa98d31359870eb4952b15d3163468341556c /sys-apps
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-e711284a818b744e657d56c216288db01df2295f.tar.gz
gentoo-2-e711284a818b744e657d56c216288db01df2295f.tar.bz2
gentoo-2-e711284a818b744e657d56c216288db01df2295f.zip
stable on ppc64, bug #61735 (small fix for s390 as well)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/ChangeLog5
-rw-r--r--sys-apps/coreutils/coreutils-5.2.1.ebuild7
-rw-r--r--sys-apps/coreutils/files/coreutils-5.2.1-unamefix.patch15
3 files changed, 24 insertions, 3 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index ef69468c2edd..94520436b9a4 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.110 2004/08/26 01:50:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.111 2004/08/26 12:21:02 tgall Exp $
+
+ 26 Aug 2004; Tom Gall <tgall@gentoo.org> coreutils-5.2.1.ebuild:
+ fix ppc64 and s390, bug #61735
*coreutils-5.2.1-r2 (25 Aug 2004)
diff --git a/sys-apps/coreutils/coreutils-5.2.1.ebuild b/sys-apps/coreutils/coreutils-5.2.1.ebuild
index 23a35e4071b7..133116a33600 100644
--- a/sys-apps/coreutils/coreutils-5.2.1.ebuild
+++ b/sys-apps/coreutils/coreutils-5.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1.ebuild,v 1.12 2004/08/15 18:16:21 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.2.1.ebuild,v 1.13 2004/08/26 12:21:02 tgall Exp $
inherit eutils flag-o-matic
@@ -20,7 +20,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc mips alpha arm hppa amd64 ia64 ~ppc64 ~s390"
+KEYWORDS="x86 ~ppc ~sparc mips alpha arm hppa amd64 ia64 ppc64 ~s390"
IUSE="nls build acl selinux static uclibc"
RDEPEND="selinux? ( sys-libs/libselinux )
@@ -72,6 +72,9 @@ src_unpack() {
EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/extra
use selinux && EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/selinux
+
+ # this fixes bug #61735 (which was also a general b0rk-age)
+ epatch ${FILESDIR}/coreutils-5.2.1-unamefix.patch
}
src_compile() {
diff --git a/sys-apps/coreutils/files/coreutils-5.2.1-unamefix.patch b/sys-apps/coreutils/files/coreutils-5.2.1-unamefix.patch
new file mode 100644
index 000000000000..8d0391fe2e91
--- /dev/null
+++ b/sys-apps/coreutils/files/coreutils-5.2.1-unamefix.patch
@@ -0,0 +1,15 @@
+--- src/uname.c.orig 2004-08-26 07:08:06.064972152 -0500
++++ src/uname.c 2004-08-26 07:08:44.153906792 -0500
+@@ -177,9 +177,11 @@
+ "cpu model", "system type"
+ #elif defined(PPC)
+ "cpu", "machine"
++ #elif defined(__powerpc64__)
++ "cpu", "machine"
+ #elif defined(__arm__)
+ "Processor", "Hardware"
+- #elif defined(__s390__) || defined(__s390x__
++ #elif defined(__s390__) || defined(__s390x__)
+ "Type", "Manufacturer"
+ #else
+ "???", "???"