summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-27 09:38:00 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-27 09:38:00 +0000
commit23cd8ebb1673aa439a2d80e7331d82af44f78011 (patch)
tree66aedc5b319bc8f3a0c69e449e5e0126e9433d9b /sys-auth/libfprint
parentFix overflow. Bug #340901 (diff)
downloadgentoo-2-23cd8ebb1673aa439a2d80e7331d82af44f78011.tar.gz
gentoo-2-23cd8ebb1673aa439a2d80e7331d82af44f78011.tar.bz2
gentoo-2-23cd8ebb1673aa439a2d80e7331d82af44f78011.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/libfprint')
-rw-r--r--sys-auth/libfprint/ChangeLog8
-rw-r--r--sys-auth/libfprint/libfprint-0.3.0.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-auth/libfprint/ChangeLog b/sys-auth/libfprint/ChangeLog
index a513ce5bc2b2..36816d8634c4 100644
--- a/sys-auth/libfprint/ChangeLog
+++ b/sys-auth/libfprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/libfprint
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.1 2010/10/17 00:54:13 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.2 2010/10/27 09:38:00 xmw Exp $
+
+*libfprint-0.3.0 (27 Oct 2010)
+
+ 27 Oct 2010; Michael Weber <xmw@gentoo.org> +libfprint-0.3.0.ebuild:
+ Version bump to new upstream location, closing bug #341639, thanks Jan
+ Buecken <jb.faq@gmx.de>
*libfprint-0.1.0_pre2 (17 Oct 2010)
*libfprint-0.0.6 (17 Oct 2010)
diff --git a/sys-auth/libfprint/libfprint-0.3.0.ebuild b/sys-auth/libfprint/libfprint-0.3.0.ebuild
new file mode 100644
index 000000000000..5a9021fb3509
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.3.0.ebuild,v 1.1 2010/10/27 09:38:00 xmw Exp $
+
+EAPI=3
+
+inherit autotools versionator
+
+MY_PV="v_$(replace_all_version_separators _)"
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X debug +examples static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libusb:1
+ dev-libs/nss
+ x11-libs/gtk+
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ X? ( examples? (
+ x11-libs/libXext
+ x11-libs/libXv ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_PV}
+
+src_prepare() {
+ mkdir m4 || die
+ eautoreconf
+}
+
+pkg_setup() {
+ einfo
+ elog "This version does not support fdu2000 and upektc (yet)."
+ einfo
+}
+
+src_configure() {
+ local my_conf="$(use_enable examples examples-build)"
+ if use X ; then
+ my_conf="${my_conf} $(use_enable examples x11-examples-build)"
+ else
+ my_conf="${my_conf} --disable-x11-examples-build"
+ fi
+ econf ${my_conf} \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ if use examples ; then
+ dobin examples/{enroll,img_capture,verify{,_live}} || die
+ if use X ; then
+ dobin examples/img_capture_continuous || die
+ fi
+ fi
+ dodoc AUTHORS HACKING NEWS README THANKS TODO || die
+}