summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-03-18 22:51:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-03-18 22:51:47 +0000
commiteb523aea647710a7ce5cf7c6310f2f7f346c8092 (patch)
tree4b0277de3b33a3bc2e9d25c6c1138fe515a393ce /sys-auth/libnss-cache/files
parentVersion bump. (diff)
downloadgentoo-2-eb523aea647710a7ce5cf7c6310f2f7f346c8092.tar.gz
gentoo-2-eb523aea647710a7ce5cf7c6310f2f7f346c8092.tar.bz2
gentoo-2-eb523aea647710a7ce5cf7c6310f2f7f346c8092.zip
Update the patch and ebuild to use DESTDIR and PREFIX sanely. Add ~x86.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/libnss-cache/files')
-rw-r--r--sys-auth/libnss-cache/files/0.1-make-install.patch20
1 files changed, 14 insertions, 6 deletions
diff --git a/sys-auth/libnss-cache/files/0.1-make-install.patch b/sys-auth/libnss-cache/files/0.1-make-install.patch
index 3281d0c4c7e1..c245f2d25308 100644
--- a/sys-auth/libnss-cache/files/0.1-make-install.patch
+++ b/sys-auth/libnss-cache/files/0.1-make-install.patch
@@ -1,12 +1,12 @@
---- libnss-cache/Makefile 2009-03-17 20:42:15.128063498 -0700
-+++ libnss-cache/Makefile 2009-03-17 20:38:33.059408526 -0700
-@@ -3,14 +3,16 @@
+diff -Nuar libnss-cache.orig/Makefile libnss-cache/Makefile
+--- libnss-cache.orig/Makefile 2008-03-22 20:22:50.000000000 -0700
++++ libnss-cache/Makefile 2009-03-18 15:45:19.244473770 -0700
+@@ -3,19 +3,21 @@
CFLAGS=-Wall -fPIC
LIBRARY=libnss_cache.so.2.0
LINKS=libnss_cache.so.2 libnss_cache.so
--PREFIX=/usr
-+DESTDIR=/
-+PREFIX=$(DESTDIR)/usr
++DESTDIR=
+ PREFIX=/usr
BUILD=.libs
LIBDIR=$(PREFIX)/lib
+SONAME=libnss_cache.so.2
@@ -19,3 +19,11 @@
clean:
rm -rf $(BUILD)
+
+ install:
+- [ -d $(LIBDIR) ] || install -d $(LIBDIR)
+- install $(BUILD)/$(LIBRARY) $(LIBDIR)
+- cd $(LIBDIR); for link in $(LINKS); do ln -sf $(LIBRARY) $$link ; done
++ [ -d $(DESTDIR)/$(PREFIX)/$(LIBDIR) ] || install -d $(DESTDIR)/$(PREFIX)/$(LIBDIR)
++ install $(BUILD)/$(LIBRARY) $(DESTDIR)/$(PREFIX)/$(LIBDIR)
++ cd $(DESTDIR)/$(PREFIX)/$(LIBDIR); for link in $(LINKS); do ln -sf $(LIBRARY) $$link ; done