summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2006-09-19 19:55:26 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2006-09-19 19:55:26 +0000
commit896a5ef87882dccf1b4112a60232b380d017c5a4 (patch)
treecfff36014c4f251021c3f02fa53ffb95519fe055 /sys-auth/nss_ldap
parentAdding strip to RESTRICT for bug #137819. (diff)
downloadgentoo-2-896a5ef87882dccf1b4112a60232b380d017c5a4.tar.gz
gentoo-2-896a5ef87882dccf1b4112a60232b380d017c5a4.tar.bz2
gentoo-2-896a5ef87882dccf1b4112a60232b380d017c5a4.zip
Bump to new version
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sys-auth/nss_ldap')
-rw-r--r--sys-auth/nss_ldap/ChangeLog7
-rw-r--r--sys-auth/nss_ldap/files/digest-nss_ldap-2533
-rw-r--r--sys-auth/nss_ldap/nss_ldap-253.ebuild70
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-auth/nss_ldap/ChangeLog b/sys-auth/nss_ldap/ChangeLog
index ce915bdac3c8..1ea8493c7179 100644
--- a/sys-auth/nss_ldap/ChangeLog
+++ b/sys-auth/nss_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/nss_ldap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.27 2006/08/21 21:29:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.28 2006/09/19 19:55:26 hansmi Exp $
+
+*nss_ldap-253 (19 Sep 2006)
+
+ 19 Sep 2006; Michael Hanselmann <hansmi@gentoo.org> +nss_ldap-253.ebuild:
+ Bump to new version (approved by robbat2 on IRC).
*nss_ldap-252 (21 Aug 2006)
diff --git a/sys-auth/nss_ldap/files/digest-nss_ldap-253 b/sys-auth/nss_ldap/files/digest-nss_ldap-253
new file mode 100644
index 000000000000..3aa847cff61c
--- /dev/null
+++ b/sys-auth/nss_ldap/files/digest-nss_ldap-253
@@ -0,0 +1,3 @@
+MD5 e3d37f59402b01c9cbf8f7ee888b3e6a nss_ldap-253.tar.gz 228278
+RMD160 a129985fe6b27a481efa94e07e994cbcdbb6867c nss_ldap-253.tar.gz 228278
+SHA256 c2caa483d171304f08a7e9a6cad7569ace5bc7f4f297ddd470e940799c6f190c nss_ldap-253.tar.gz 228278
diff --git a/sys-auth/nss_ldap/nss_ldap-253.ebuild b/sys-auth/nss_ldap/nss_ldap-253.ebuild
new file mode 100644
index 000000000000..6bda6c0b841f
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-253.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-253.ebuild,v 1.1 2006/09/19 19:55:26 hansmi Exp $
+
+inherit fixheadtails eutils gnuconfig multilib
+
+IUSE="debug sasl"
+
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )"
+RDEPEND="${DEPEND}
+ !<net-fs/autofs-4.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/nsswitch.ldap.diff
+ epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
+ epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
+ sed -i.orig \
+ -e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
+ ${S}/ldap.conf || die "failed to clean up initial version marker"
+ # fix head/tail stuff
+ ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ # fix build borkage
+ for i in Makefile.{in,am}; do
+ sed -i.orig \
+ -e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
+ ${S}/$i
+ done
+ # update config.{guess,sub}
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debugging"
+
+ econf \
+ --with-ldap-lib=openldap \
+ --libdir=/$(get_libdir) \
+ --enable-schema-mapping \
+ --enable-paged-results \
+ --enable-rfc2307bis \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /$(get_libdir)
+
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins ldap.conf
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS \
+ COPYING CVSVersionInfo.txt README nsswitch.ldap certutil
+ docinto docs; dodoc doc/*
+}