summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-07-12 04:37:09 +0000
committerAli Polatel <hawking@gentoo.org>2007-07-12 04:37:09 +0000
commitdc537e2f650e45910ef9946e5eed9705ee92bfd4 (patch)
tree770112588f8576f4e6721623d3270170f1e3db64 /sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
parentwhitespace (diff)
downloadgentoo-2-dc537e2f650e45910ef9946e5eed9705ee92bfd4.tar.gz
gentoo-2-dc537e2f650e45910ef9946e5eed9705ee92bfd4.tar.bz2
gentoo-2-dc537e2f650e45910ef9946e5eed9705ee92bfd4.zip
Import from gentoo-sunrise, bug #160755
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild')
-rw-r--r--sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild b/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
new file mode 100644
index 000000000000..f7dff4711500
--- /dev/null
+++ b/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.1.ebuild,v 1.1 2007/07/12 04:37:09 hawking Exp $
+
+inherit toolchain-funcs pam flag-o-matic
+
+DESCRIPTION="Linux-PAM module that allows a user to be chrooted in auth, account, or session."
+HOMEPAGE="http://sourceforge.net/projects/pam-chroot/"
+SRC_URI="mirror://sourceforge/pam-chroot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-flags "-fPIC"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_chroot.so
+ dopamsecurity . chroot.conf
+
+ dodoc CREDITS TROUBLESHOOTING options || die "dodoc failed"
+}