summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-05-04 20:21:02 +0000
committerHanno Böck <hanno@gentoo.org>2010-05-04 20:21:02 +0000
commit7f5a9f292e180fc6ab05fa315ef1a72566336333 (patch)
tree259040b9de7c15ed29afb797c3b539831c9cb923 /sys-auth/pam_mount
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-7f5a9f292e180fc6ab05fa315ef1a72566336333.tar.gz
gentoo-2-7f5a9f292e180fc6ab05fa315ef1a72566336333.tar.bz2
gentoo-2-7f5a9f292e180fc6ab05fa315ef1a72566336333.zip
pam_mount: Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 019698683998..d0ffa156758f 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.39 2010/04/23 20:35:10 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.40 2010/05/04 20:21:02 hanno Exp $
+
+*pam_mount-2.1 (04 May 2010)
+
+ 04 May 2010; Hanno Boeck <hanno@gentoo.org> +pam_mount-2.1.ebuild:
+ Version bump.
23 Apr 2010; Hanno Boeck <hanno@gentoo.org> pam_mount-2.0.ebuild:
Adjust cryptsetup dependency.
diff --git a/sys-auth/pam_mount/pam_mount-2.1.ebuild b/sys-auth/pam_mount/pam_mount-2.1.ebuild
new file mode 100644
index 000000000000..d579eaf9ec83
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.1.ebuild,v 1.1 2010/05/04 20:21:02 hanno Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.4
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.4
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ sys-process/lsof"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}