summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-07-31 14:52:55 +0000
committerHanno Böck <hanno@gentoo.org>2010-07-31 14:52:55 +0000
commitd155b075327340ac1718746ecb197a9625e1445e (patch)
tree75895a40d6212ee59ba99f023d2d613a8570e3f9 /sys-auth/pam_mount
parentStable on amd64 wrt bug #330075 (diff)
downloadgentoo-2-d155b075327340ac1718746ecb197a9625e1445e.tar.gz
gentoo-2-d155b075327340ac1718746ecb197a9625e1445e.tar.bz2
gentoo-2-d155b075327340ac1718746ecb197a9625e1445e.zip
pam_mount bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-2.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 2efd5b7d62a5..e3e94b498be0 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.43 2010/07/27 18:51:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.44 2010/07/31 14:52:55 hanno Exp $
+
+*pam_mount-2.4 (31 Jul 2010)
+
+ 31 Jul 2010; Hanno Boeck <hanno@gentoo.org> +pam_mount-2.4.ebuild:
+ Version bump.
27 Jul 2010; Pacho Ramos <pacho@gentoo.org> pam_mount-2.1.ebuild:
amd64 stable, bug 264658
diff --git a/sys-auth/pam_mount/pam_mount-2.4.ebuild b/sys-auth/pam_mount/pam_mount-2.4.ebuild
new file mode 100644
index 000000000000..b1fb1b6ea0fb
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.4.ebuild,v 1.1 2010/07/31 14:52:55 hanno Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.4
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ dev-util/pkgconfig
+ app-arch/xz-utils"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-3.4
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.1.0
+ sys-process/lsof"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}