summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-05-20 20:43:14 +0000
committerHanno Böck <hanno@gentoo.org>2008-05-20 20:43:14 +0000
commitde568c1aeaedb0af9010871d18a40da0fb58a547 (patch)
tree97584f60b067967e64085558f861670a4684e2b2 /sys-auth/pam_mount
parentVersion bump (diff)
downloadgentoo-2-de568c1aeaedb0af9010871d18a40da0fb58a547.tar.gz
gentoo-2-de568c1aeaedb0af9010871d18a40da0fb58a547.tar.bz2
gentoo-2-de568c1aeaedb0af9010871d18a40da0fb58a547.zip
pam_mount bump
(Portage version: 2.1.5.2)
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-0.38.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 188639921eaa..5781e2344ed3 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.14 2008/04/13 23:23:32 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.15 2008/05/20 20:43:14 hanno Exp $
+
+*pam_mount-0.38 (20 May 2008)
+
+ 20 May 2008; Hanno Boeck <hanno@gentoo.org> +pam_mount-0.38.ebuild:
+ Version bump.
*pam_mount-0.35.1 (12 Apr 2008)
diff --git a/sys-auth/pam_mount/pam_mount-0.38.ebuild b/sys-auth/pam_mount/pam_mount-0.38.ebuild
new file mode 100644
index 000000000000..ad3f831a81e9
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-0.38.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-0.38.ebuild,v 1.1 2008/05/20 20:43:14 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.15
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.72
+ dev-libs/openssl
+ >=sys-libs/libhx-1.15
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}