summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-01-17 16:53:25 +0000
committerUlrich Müller <ulm@gentoo.org>2008-01-17 16:53:25 +0000
commit9405f77b5eef23177caaadea6da17a1110183356 (patch)
tree41b49235921832e1b83494267917af6169390efe /sys-auth/pam_skey/pam_skey-1.1.5.ebuild
parentVersion bump, added a test function, doc flag. lapack is not needed anymore b... (diff)
downloadgentoo-2-9405f77b5eef23177caaadea6da17a1110183356.tar.gz
gentoo-2-9405f77b5eef23177caaadea6da17a1110183356.tar.bz2
gentoo-2-9405f77b5eef23177caaadea6da17a1110183356.zip
Fix -fPIC issue.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sys-auth/pam_skey/pam_skey-1.1.5.ebuild')
-rw-r--r--sys-auth/pam_skey/pam_skey-1.1.5.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-auth/pam_skey/pam_skey-1.1.5.ebuild b/sys-auth/pam_skey/pam_skey-1.1.5.ebuild
index 976e47a5c906..0052c1fce606 100644
--- a/sys-auth/pam_skey/pam_skey-1.1.5.ebuild
+++ b/sys-auth/pam_skey/pam_skey-1.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5.ebuild,v 1.1 2008/01/17 12:24:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_skey/pam_skey-1.1.5.ebuild,v 1.2 2008/01/17 16:53:25 ulm Exp $
inherit eutils pam autotools multilib
@@ -30,7 +30,8 @@ src_unpack() {
}
src_compile() {
- econf --libdir="/$(get_libdir)" || die "econf failed"
+ econf --libdir="/$(get_libdir)" CFLAGS="${CFLAGS} -fPIC" \
+ || die "econf failed"
emake || die "emake failed"
}