summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-09 15:24:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-09 15:24:59 +0000
commit987a89bf8d841db8592e5b02970de231a0fbfc80 (patch)
tree1c883f6f4aa8cb80440923e415e1e4bc577b18c7 /sys-auth/pam_ssh/pam_ssh-1.92.ebuild
parentNew version with sparc patches for sanitized headers (diff)
downloadgentoo-2-987a89bf8d841db8592e5b02970de231a0fbfc80.tar.gz
gentoo-2-987a89bf8d841db8592e5b02970de231a0fbfc80.tar.bz2
gentoo-2-987a89bf8d841db8592e5b02970de231a0fbfc80.zip
Version bump as per bug #166087.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-auth/pam_ssh/pam_ssh-1.92.ebuild')
-rw-r--r--sys-auth/pam_ssh/pam_ssh-1.92.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/pam_ssh/pam_ssh-1.92.ebuild b/sys-auth/pam_ssh/pam_ssh-1.92.ebuild
new file mode 100644
index 000000000000..ebb1970a9c75
--- /dev/null
+++ b/sys-auth/pam_ssh/pam_ssh-1.92.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ssh/pam_ssh-1.92.ebuild,v 1.1 2007/02/09 15:24:59 flameeyes Exp $
+
+inherit pam eutils
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.bz2"
+
+RESTRICT="nomirror confcache"
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# Doesn't work on OpenPAM.
+DEPEND="sys-libs/pam
+ sys-devel/libtool"
+
+RDEPEND="sys-libs/pam
+ virtual/ssh"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.91-debian.patch" #105546
+ epatch "${FILESDIR}/${PN}-1.91-syslog.patch" # glibc-2.4
+}
+
+src_compile() {
+ econf \
+ "--with-pam-dir=$(getpam_mod_dir)" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO "${FILESDIR}/system-auth.example"
+}
+
+pkg_postinst() {
+ einfo "You can find an example system-auth file that uses this"
+ einfo "library in /usr/share/doc/${PF}"
+}