summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-08 22:16:00 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-08 22:16:00 +0000
commitd95fd375459e539126324fc4643f64a132c91cbb (patch)
treeae5d9883edfceb66061f12ca58cc2f24224f82a0 /sys-auth/polkit-qt
parentFix LICENSE, bug 298556. (diff)
downloadgentoo-2-d95fd375459e539126324fc4643f64a132c91cbb.tar.gz
gentoo-2-d95fd375459e539126324fc4643f64a132c91cbb.tar.bz2
gentoo-2-d95fd375459e539126324fc4643f64a132c91cbb.zip
[sys-auth/polkit-qt] Initial import
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/polkit-qt')
-rw-r--r--sys-auth/polkit-qt/ChangeLog10
-rw-r--r--sys-auth/polkit-qt/metadata.xml5
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild41
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/ChangeLog b/sys-auth/polkit-qt/ChangeLog
new file mode 100644
index 000000000000..7bb8946b6bec
--- /dev/null
+++ b/sys-auth/polkit-qt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-auth/polkit-qt
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/ChangeLog,v 1.1 2010/02/08 22:16:00 alexxy Exp $
+
+*polkit-qt-0.95.1 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +polkit-qt-0.95.1.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/sys-auth/polkit-qt/metadata.xml b/sys-auth/polkit-qt/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/sys-auth/polkit-qt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild b/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild
new file mode 100644
index 000000000000..eae53a98dbea
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-qt/polkit-qt-0.95.1.ebuild,v 1.1 2010/02/08 22:16:00 alexxy Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+MY_P="${P/qt/qt-1}"
+
+DESCRIPTION="PolicyKit Qt4 API wrapper library."
+HOMEPAGE="http://kde.org/"
+SRC_URI="mirror://kde/stable/polkit-qt-1/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug examples"
+
+COMMON_DEPEND="
+ >=sys-auth/polkit-0.95
+ x11-libs/qt-gui[dbus]
+"
+DEPEND="${COMMON_DEPEND}
+ kde-base/automoc
+"
+RDEPEND="${COMMON_DEPEND}
+ examples? ( !sys-auth/policykit-qt[examples] )
+"
+
+DOCS="AUTHORS README README.porting TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ )
+
+ cmake-utils_src_configure
+}