summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-07-24 06:34:33 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2012-07-24 06:34:33 +0000
commit090ebccba14e06696b6f2a1013b996c75a3349f3 (patch)
treea4198ee84cd54d3d87fdf05b10fbe79bc4f35850 /sys-auth
parentDrop the src_compile() as pkgconf has a new buildsys that is verbose by default. (diff)
downloadgentoo-2-090ebccba14e06696b6f2a1013b996c75a3349f3.tar.gz
gentoo-2-090ebccba14e06696b6f2a1013b996c75a3349f3.tar.bz2
gentoo-2-090ebccba14e06696b6f2a1013b996c75a3349f3.zip
updated package name and fixes bugs 287727 and 234555
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-ldapd/ChangeLog14
-rw-r--r--sys-auth/nss-ldapd/files/nslcd-init35
-rw-r--r--sys-auth/nss-ldapd/metadata.xml4
-rw-r--r--sys-auth/nss-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild (renamed from sys-auth/nss-ldapd/nss-ldapd-0.6.7-r1.ebuild)6
-rw-r--r--sys-auth/nss-ldapd/nss-pam-ldapd-0.8.10.ebuild84
5 files changed, 135 insertions, 8 deletions
diff --git a/sys-auth/nss-ldapd/ChangeLog b/sys-auth/nss-ldapd/ChangeLog
index d3942f527562..59dff4601198 100644
--- a/sys-auth/nss-ldapd/ChangeLog
+++ b/sys-auth/nss-ldapd/ChangeLog
@@ -1,6 +1,14 @@
-# ChangeLog for sys-auth/nss-ldapd
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/ChangeLog,v 1.4 2009/04/02 18:50:35 cardoe Exp $
+# ChangeLog for sys-auth/nss-pam-ldapd
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/ChangeLog,v 1.5 2012/07/24 06:34:33 prometheanfire Exp $
+
+*nss-pam-ldapd-0.8.10 (24 Jul 2012)
+*nss-pam-ldapd-0.6.7-r1 (24 Jul 2012)
+
+ 24 Jul 2012; Matthew Thode <prometheanfire@gentoo.org>
+ +nss-pam-ldapd-0.6.7-r1.ebuild, +nss-pam-ldapd-0.8.10.ebuild,
+ +files/nslcd-init:
+ moving to nss-pam-ldapd, also fixes bugs #287727 #234555
*nss-ldapd-0.6.7-r1 (02 Apr 2009)
diff --git a/sys-auth/nss-ldapd/files/nslcd-init b/sys-auth/nss-ldapd/files/nslcd-init
new file mode 100644
index 000000000000..a472a9035a6d
--- /dev/null
+++ b/sys-auth/nss-ldapd/files/nslcd-init
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/files/nslcd-init,v 1.1 2012/07/24 06:34:33 prometheanfire Exp $
+
+extra_commands="checkconfig"
+
+depend() {
+ need net
+ use dns logger
+}
+
+checkconfig() {
+ if [ ! -f /etc/nslcd.conf ] ; then
+ eerror "Please create /etc/nslcd.conf"
+ eerror "Example config: /usr/share/nss-ldapd/nslcd.conf"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+
+ ebegin "Starting nslcd"
+ start-stop-daemon --start --pidfile /var/run/nslcd/nslcd.pid \
+ --exec /usr/sbin/nslcd
+ eend $? "Failed to start nslcd"
+}
+
+stop() {
+ ebegin "Stopping nslcd"
+ start-stop-daemon --stop --pidfile /var/run/nslcd/nslcd.pid
+ eend $? "Failed to stop nslcd"
+}
diff --git a/sys-auth/nss-ldapd/metadata.xml b/sys-auth/nss-ldapd/metadata.xml
index e8b7c340d5db..de55eff773c9 100644
--- a/sys-auth/nss-ldapd/metadata.xml
+++ b/sys-auth/nss-ldapd/metadata.xml
@@ -2,8 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>cardoe@gentoo.org</email>
- <name>Doug Goldstein</name>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
</maintainer>
</pkgmetadata>
diff --git a/sys-auth/nss-ldapd/nss-ldapd-0.6.7-r1.ebuild b/sys-auth/nss-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild
index f25e159cf8ca..bcfa2b2f882b 100644
--- a/sys-auth/nss-ldapd/nss-ldapd-0.6.7-r1.ebuild
+++ b/sys-auth/nss-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-ldapd-0.6.7-r1.ebuild,v 1.1 2009/04/02 18:50:35 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-pam-ldapd-0.6.7-r1.ebuild,v 1.1 2012/07/24 06:34:33 prometheanfire Exp $
inherit multilib
DESCRIPTION="NSS module for name lookups using LDAP"
HOMEPAGE="http://ch.tudelft.nl/~arthur/nss-ldapd/"
-SRC_URI="http://ch.tudelft.nl/~arthur/nss-ldapd/${P}.tar.gz"
+SRC_URI="http://ch.tudelft.nl/~arthur/nss-ldapd/nss-ldapd-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
diff --git a/sys-auth/nss-ldapd/nss-pam-ldapd-0.8.10.ebuild b/sys-auth/nss-ldapd/nss-pam-ldapd-0.8.10.ebuild
new file mode 100644
index 000000000000..c7933d263677
--- /dev/null
+++ b/sys-auth/nss-ldapd/nss-pam-ldapd-0.8.10.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-pam-ldapd-0.8.10.ebuild,v 1.1 2012/07/24 06:34:33 prometheanfire Exp $
+
+EAPI=4
+
+inherit multilib user
+
+DESCRIPTION="NSS module for name lookups using LDAP"
+HOMEPAGE="http://arthurdejong.org/nss-pam-ldapd/"
+SRC_URI="http://arthurdejong.org/nss-pam-ldapd/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug kerberos sasl +pam"
+
+DEPEND="net-nds/openldap
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ !sys-auth/nss_ldap"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup nslcd
+ enewuser nslcd -1 -1 -1 nslcd
+}
+
+src_configure() {
+ # nss libraries always go in /lib on Gentoo
+ myconf="--enable-warnings
+ --with-ldap-lib=openldap
+ --with-ldap-conf-file=/etc/nslcd.conf
+ --with-nslcd-pidfile=/var/run/nslcd/nslcd.pid
+ --with-nslcd-socket=/var/run/nslcd/socket
+ --libdir=/$(get_libdir)
+ $(use_enable debug)
+ $(use_enable kerberos)
+ $(use_enable pam)"
+
+ if use x86-fbsd; then
+ myconf+=" --with-nss-flavour=freebsd"
+ else
+ myconf+=" --with-nss-flavour=glibc"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc NEWS ChangeLog AUTHORS README
+
+ # for socket and pid file
+ keepdir /var/run/nslcd
+
+ # init script
+ newinitd "${FILESDIR}"/nslcd-init nslcd
+
+ # make an example copy
+ insinto /usr/share/nss-pam-ldapd
+ doins nslcd.conf
+
+ fperms o-r /etc/nslcd.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "For this to work you must configure /etc/nslcd.conf"
+ elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
+ elog
+ elog "In order to use nss-pam-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ elog
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
+ elog
+ elog "If you are upgrading, keep in mind that /etc/nss-ldapd.conf"
+ elog " is now named /etc/nslcd.conf"
+ elog
+}