summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-31 01:07:14 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-31 01:07:14 +0000
commit0c9e723d936aa368965fb495cb2f00b4376eac56 (patch)
tree1add28e6276186eebb538ad9cf9c389a709d51dd /sys-auth
parentremove bioapi from p.mask until fprint has a GUI replacement (diff)
downloadgentoo-2-0c9e723d936aa368965fb495cb2f00b4376eac56.tar.gz
gentoo-2-0c9e723d936aa368965fb495cb2f00b4376eac56.tar.bz2
gentoo-2-0c9e723d936aa368965fb495cb2f00b4376eac56.zip
Version bump and cleanup.
(Portage version: 2.1.4_rc12)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_bioapi/ChangeLog7
-rw-r--r--sys-auth/pam_bioapi/files/digest-pam_bioapi-0.4.03
-rw-r--r--sys-auth/pam_bioapi/pam_bioapi-0.4.0.ebuild34
3 files changed, 43 insertions, 1 deletions
diff --git a/sys-auth/pam_bioapi/ChangeLog b/sys-auth/pam_bioapi/ChangeLog
index 584281833466..d872e1b2c7d5 100644
--- a/sys-auth/pam_bioapi/ChangeLog
+++ b/sys-auth/pam_bioapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_bioapi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.3 2007/09/05 20:22:00 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/ChangeLog,v 1.4 2007/12/31 01:07:13 vapier Exp $
+
+*pam_bioapi-0.4.0 (31 Dec 2007)
+
+ 31 Dec 2007; Mike Frysinger <vapier@gentoo.org> +pam_bioapi-0.4.0.ebuild:
+ Version bump and cleanup.
05 Sep 2007; Chris Gianelloni <wolf31o2@gentoo.org> metadata.xml:
Changed maintainer to Mike Frysinger <vapier@gentoo.org>.
diff --git a/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.4.0 b/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.4.0
new file mode 100644
index 000000000000..e4fb4d3c928b
--- /dev/null
+++ b/sys-auth/pam_bioapi/files/digest-pam_bioapi-0.4.0
@@ -0,0 +1,3 @@
+MD5 0896c6549be3720d358b1e8507c36a4d pam_bioapi-0.4.0.tar.gz 383529
+RMD160 4d141426278535a8cb8a079300457d1e0a97fcf5 pam_bioapi-0.4.0.tar.gz 383529
+SHA256 635df4a27c3f9485a2eabbc672f0cf2771a96756792b5f4078481f2df9bceb8c pam_bioapi-0.4.0.tar.gz 383529
diff --git a/sys-auth/pam_bioapi/pam_bioapi-0.4.0.ebuild b/sys-auth/pam_bioapi/pam_bioapi-0.4.0.ebuild
new file mode 100644
index 000000000000..0a757db8c040
--- /dev/null
+++ b/sys-auth/pam_bioapi/pam_bioapi-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_bioapi/pam_bioapi-0.4.0.ebuild,v 1.1 2007/12/31 01:07:13 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="PAM interface to bioapi package"
+HOMEPAGE="http://code.google.com/p/pam-bioapi/"
+SRC_URI="http://pam-bioapi.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-auth/bioapi
+ sys-libs/pam
+ sys-auth/tfm-fingerprint
+ dev-db/sqlite"
+
+src_compile() {
+ econf --sbindir=/sbin || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/{lib*.so*,security} "${D}"/$(get_libdir)/ || die
+ rm -f "${D}"/$(get_libdir)/security/*.la
+ gen_usr_ldscript libbirdb.so libbirdb_sqlite3.so
+}