summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-10-28 13:35:57 +0000
committerRick Farina <zerochaos@gentoo.org>2013-10-28 13:35:57 +0000
commit1257f25849dfa6650190cc464910063a29443da6 (patch)
treea31b9f46c615a0983fea80142bbc2ad260b7fa85 /sys-auth
parentRemove old (diff)
downloadgentoo-2-1257f25849dfa6650190cc464910063a29443da6.tar.gz
gentoo-2-1257f25849dfa6650190cc464910063a29443da6.tar.bz2
gentoo-2-1257f25849dfa6650190cc464910063a29443da6.zip
version bump, new homepage, new download site, remove unneeded(?) patch
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_yubico/ChangeLog8
-rw-r--r--sys-auth/pam_yubico/metadata.xml3
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.14.ebuild41
3 files changed, 48 insertions, 4 deletions
diff --git a/sys-auth/pam_yubico/ChangeLog b/sys-auth/pam_yubico/ChangeLog
index 725dc856f767..62481cdecf08 100644
--- a/sys-auth/pam_yubico/ChangeLog
+++ b/sys-auth/pam_yubico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/pam_yubico
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/ChangeLog,v 1.2 2013/04/22 14:04:54 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/ChangeLog,v 1.3 2013/10/28 13:35:57 zerochaos Exp $
+
+*pam_yubico-2.14 (28 Oct 2013)
+
+ 28 Oct 2013; Rick Farina <zerochaos@gentoo.org> +pam_yubico-2.14.ebuild,
+ metadata.xml:
+ version bump, new homepage, new download site, remove unneeded(?) patch
22 Apr 2013; Rick Farina <zerochaos@gentoo.org> pam_yubico-2.13.ebuild:
minor fix to deps and .la fix
diff --git a/sys-auth/pam_yubico/metadata.xml b/sys-auth/pam_yubico/metadata.xml
index 6cbb2f1f5ddf..5fcbf8e1851a 100644
--- a/sys-auth/pam_yubico/metadata.xml
+++ b/sys-auth/pam_yubico/metadata.xml
@@ -5,9 +5,6 @@
<email>zerochaos@gentoo.org</email>
<name>Rick Farina</name>
</maintainer>
-<maintainer>
-<email>anyone@whowantsto.com</email>
-</maintainer>
<longdescription lang="en">
</longdescription>
</pkgmetadata>
diff --git a/sys-auth/pam_yubico/pam_yubico-2.14.ebuild b/sys-auth/pam_yubico/pam_yubico-2.14.ebuild
new file mode 100644
index 000000000000..a50336b32837
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.14.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_yubico/pam_yubico-2.14.ebuild,v 1.1 2013/10/28 13:35:57 zerochaos Exp $
+
+EAPI=5
+inherit multilib
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/yubico-pam"
+SRC_URI="http://opensource.yubico.com/yubico-pam/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap"
+
+DEPEND="virtual/pam
+ >=sys-auth/ykclient-2.4
+ >=sys-auth/ykpers-1.6
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}"
+
+#src_prepare() {
+# epatch "${FILESDIR}/2.11-drop_privs.patch"
+# eautoreconf
+#}
+
+src_configure() {
+ #challenge response could be optional but that seems horribly dangerous to me
+ econf \
+ --with-cr \
+ $(use_with ldap) \
+ --with-pam-dir=/$(get_libdir)/security
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README doc/*
+ #prune_libtool_files #why doesn't this work?
+ find "${D}" -name '*.la' -delete || die
+}