summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-08-19 02:33:08 +0000
committerRick Farina <zerochaos@gentoo.org>2014-08-19 02:33:08 +0000
commit26593eb0843ef954457fb968d0736361be31739e (patch)
tree3f53647539e136b9ee9fbe2370b1362f68a1e1ab /sys-auth
parentversion bump, bug 513944 (diff)
downloadgentoo-2-26593eb0843ef954457fb968d0736361be31739e.tar.gz
gentoo-2-26593eb0843ef954457fb968d0736361be31739e.tar.bz2
gentoo-2-26593eb0843ef954457fb968d0736361be31739e.zip
version bump, bug 513944
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykpers/ChangeLog9
-rw-r--r--sys-auth/ykpers/ykpers-1.15.2.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
index 450b3fe1c3fa..41d2d5521e84 100644
--- a/sys-auth/ykpers/ChangeLog
+++ b/sys-auth/ykpers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykpers
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.11 2013/10/28 13:50:08 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.12 2014/08/19 02:33:08 zerochaos Exp $
+
+*ykpers-1.15.2 (19 Aug 2014)
+
+ 19 Aug 2014; Rick Farina <zerochaos@gentoo.org> +ykpers-1.15.2.ebuild:
+ version bump, bug 513944
*ykpers-1.14.1 (28 Oct 2013)
diff --git a/sys-auth/ykpers/ykpers-1.15.2.ebuild b/sys-auth/ykpers/ykpers-1.15.2.ebuild
new file mode 100644
index 000000000000..1ae6d9a0a2d4
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.15.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.15.2.ebuild,v 1.1 2014/08/19 02:33:08 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND=">=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ dodoc doc/*
+ prune_libtool_files
+
+ use consolekit && \
+ udev_dorules 70-yubikey.rules
+}