summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2015-01-04 10:10:00 +0000
committerHanno Böck <hanno@gentoo.org>2015-01-04 10:10:00 +0000
commit45bc98cadf76941efe8554d9f47fcf7c885ae60e (patch)
treeaf841c2161abd2bb0079a2299c194a86461ce301 /sys-auth
parentlibhx bump (diff)
downloadgentoo-2-45bc98cadf76941efe8554d9f47fcf7c885ae60e.tar.gz
gentoo-2-45bc98cadf76941efe8554d9f47fcf7c885ae60e.tar.bz2
gentoo-2-45bc98cadf76941efe8554d9f47fcf7c885ae60e.zip
pam_mount bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BBB51E42)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog9
-rw-r--r--sys-auth/pam_mount/pam_mount-2.15.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index efc0762b5eb8..4647a6225f23 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.77 2014/02/24 02:33:08 mattst88 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.78 2015/01/04 10:10:00 hanno Exp $
+
+*pam_mount-2.15 (04 Jan 2015)
+
+ 04 Jan 2015; <hanno@gentoo.org> +pam_mount-2.15.ebuild:
+ Bump, EAPI=5.
24 Feb 2014; Matt Turner <mattst88@gentoo.org>
-files/pam_mount-2.13-fix-build-without-cryptsetup.patch,
diff --git a/sys-auth/pam_mount/pam_mount-2.15.ebuild b/sys-auth/pam_mount/pam_mount-2.15.ebuild
new file mode 100644
index 000000000000..9d0267420cd3
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-2.15.ebuild,v 1.1 2015/01/04 10:10:00 hanno Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+COMMON_DEPEND=">=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1
+ >=dev-libs/libxml2-2.6
+ crypt? ( >=sys-fs/cryptsetup-1.1.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/util-linux-2.20"
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+}