summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 15:59:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 15:59:14 +0000
commit5ac4dd122fd7ec1b6e892d61676c7a0221445b9a (patch)
tree62be098885419e3de51606b3b8cda9aaa65549c4 /sys-auth
parentVersion bump. Drop old. (diff)
downloadgentoo-2-5ac4dd122fd7ec1b6e892d61676c7a0221445b9a.tar.gz
gentoo-2-5ac4dd122fd7ec1b6e892d61676c7a0221445b9a.tar.bz2
gentoo-2-5ac4dd122fd7ec1b6e892d61676c7a0221445b9a.zip
modernize and go multilib
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/openpam/ChangeLog10
-rw-r--r--sys-auth/openpam/openpam-20120526-r1.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/sys-auth/openpam/ChangeLog b/sys-auth/openpam/ChangeLog
index 0747591cc3c7..97bad6482ed2 100644
--- a/sys-auth/openpam/ChangeLog
+++ b/sys-auth/openpam/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/openpam
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.23 2012/10/30 12:03:57 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/ChangeLog,v 1.24 2013/08/10 15:59:14 aballier Exp $
+
+*openpam-20120526-r1 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ +openpam-20120526-r1.ebuild:
+ modernize and go multilib
*openpam-20120526 (30 Oct 2012)
diff --git a/sys-auth/openpam/openpam-20120526-r1.ebuild b/sys-auth/openpam/openpam-20120526-r1.ebuild
new file mode 100644
index 000000000000..b152a0e93a49
--- /dev/null
+++ b/sys-auth/openpam/openpam-20120526-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20120526-r1.ebuild,v 1.1 2013/08/10 15:59:14 aballier Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit multilib autotools-multilib
+
+DESCRIPTION="Open source PAM library."
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="debug vim-syntax"
+
+RDEPEND="!sys-libs/pam"
+DEPEND="sys-devel/make
+ dev-lang/perl"
+PDEPEND="sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20071221-gentoo.patch"
+ "${FILESDIR}/${PN}-20050201-nbsd.patch"
+ )
+
+DOCS=( CREDITS HISTORY RELNOTES README )
+
+src_prepare() {
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+ mkdir "${S}/m4" # Otherwise aclocal fails since ACLOCAL_AMFLAGS is set in Makefile.am
+
+ autotools-multilib_src_prepare
+}
+
+my_configure() {
+ local myeconfargs=(
+ --with-modules-dir=/$(get_libdir)/security
+ )
+ autotools-utils_src_configure
+}
+
+src_configure() {
+ multilib_parallel_foreach_abi my_configure
+}