summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-01-23 17:53:44 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-01-23 17:53:44 +0000
commit6ef6cdc655d4a535fb3720ddddd579be828579a5 (patch)
treee0821de53bfa6ed9dce19600a47706d598f3ca41 /sys-auth
parentUnmask kde (diff)
downloadgentoo-2-6ef6cdc655d4a535fb3720ddddd579be828579a5.tar.gz
gentoo-2-6ef6cdc655d4a535fb3720ddddd579be828579a5.tar.bz2
gentoo-2-6ef6cdc655d4a535fb3720ddddd579be828579a5.zip
Version bump to 0.96; lots of bugfixes, see NEWS
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog7
-rw-r--r--sys-auth/polkit/polkit-0.96.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index 9e563792b13d..8b127593a192 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.5 2010/01/06 17:59:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.6 2010/01/23 17:53:44 nirbheek Exp $
+
+*polkit-0.96 (23 Jan 2010)
+
+ 23 Jan 2010; Nirbheek Chauhan <nirbheek@gentoo.org> +polkit-0.96.ebuild:
+ Version bump to 0.96; lots of bugfixes, see NEWS
06 Jan 2010; Jeroen Roovers <jer@gentoo.org> polkit-0.95.ebuild:
Marked ~hppa (bug #296548).
diff --git a/sys-auth/polkit/polkit-0.96.ebuild b/sys-auth/polkit/polkit-0.96.ebuild
new file mode 100644
index 000000000000..244dd7ccab74
--- /dev/null
+++ b/sys-auth/polkit/polkit-0.96.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.96.ebuild,v 1.1 2010/01/23 17:53:44 nirbheek Exp $
+
+EAPI="2"
+
+inherit eutils multilib pam
+
+DESCRIPTION="Policy framework for controlling privileges for system-wide services"
+HOMEPAGE="http://hal.freedesktop.org/docs/PolicyKit"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug doc examples expat nls"
+# building w/o pam is broken, bug 291116
+# introspection pam
+
+# not mature enough
+# introspection? ( dev-libs/gobject-introspection )
+RDEPEND=">=dev-libs/glib-2.21.4
+ >=dev-libs/eggdbus-0.6
+ virtual/pam
+ expat? ( dev-libs/expat )"
+DEPEND="${RDEPEND}
+ !!>=sys-auth/policykit-0.92
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.36
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+PDEPEND=">=sys-auth/consolekit-0.4[policykit]"
+
+pkg_setup() {
+ enewgroup polkituser
+ enewuser polkituser -1 "-1" /dev/null polkituser
+}
+
+src_configure() {
+ local conf
+
+ if use expat; then
+ conf="${conf} --with-expat=/usr"
+ fi
+
+ # We define libexecdir due to fdo bug #22951
+ # easier to maintain than patching everything
+ econf ${conf} \
+ --disable-introspection \
+ --disable-ansi \
+ --disable-examples \
+ --enable-fast-install \
+ --enable-libtool-lock \
+ --enable-man-pages \
+ --disable-dependency-tracking \
+ --with-os-type=gentoo \
+ --localstatedir=/var \
+ --libexecdir='${exec_prefix}/libexec/polkit-1' \
+ --with-authfw=pam \
+ --with-pam-module-dir=$(getpam_mod_dir) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls)
+ #$(use_enable introspection)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc NEWS README AUTHORS ChangeLog || die "dodoc failed"
+
+ # We disable example compilation above, and handle it here
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/{*.c,*.policy*}
+ fi
+
+ # Need to keep a few directories around...
+ diropts -m0700 -o root -g polkituser
+ keepdir /var/run/polkit-1
+ keepdir /var/lib/polkit-1
+}