summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-01-26 20:03:07 +0000
committerHanno Böck <hanno@gentoo.org>2009-01-26 20:03:07 +0000
commit701719dbbbe79323d071ecd1c4ccedac5ac8a53a (patch)
tree4cfc05ed9c12c7d10f31602e5e6870bd4f17e4db /sys-auth
parentMarking pnp4nagios-0.4.12 ppc64 for bug 256177 (diff)
downloadgentoo-2-701719dbbbe79323d071ecd1c4ccedac5ac8a53a.tar.gz
gentoo-2-701719dbbbe79323d071ecd1c4ccedac5ac8a53a.tar.bz2
gentoo-2-701719dbbbe79323d071ecd1c4ccedac5ac8a53a.zip
pam_mount bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mount/ChangeLog7
-rw-r--r--sys-auth/pam_mount/pam_mount-1.16.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/pam_mount/ChangeLog b/sys-auth/pam_mount/ChangeLog
index 35d701380f74..92a151e47465 100644
--- a/sys-auth/pam_mount/ChangeLog
+++ b/sys-auth/pam_mount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_mount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.25 2009/01/08 21:31:44 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/ChangeLog,v 1.26 2009/01/26 20:03:07 hanno Exp $
+
+*pam_mount-1.16 (26 Jan 2009)
+
+ 26 Jan 2009; Hanno Boeck <hanno@gentoo.org> +pam_mount-1.16.ebuild:
+ Version bump.
*pam_mount-1.8 (08 Jan 2009)
diff --git a/sys-auth/pam_mount/pam_mount-1.16.ebuild b/sys-auth/pam_mount/pam_mount-1.16.ebuild
new file mode 100644
index 000000000000..3d281ca56167
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-1.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_mount/pam_mount-1.16.ebuild,v 1.1 2009/01/26 20:03:07 hanno Exp $
+
+inherit multilib
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt"
+DEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.2
+ dev-libs/libxml2
+ dev-util/pkgconfig"
+RDEPEND=">=sys-libs/pam-0.99
+ dev-libs/openssl
+ >=sys-libs/libhx-2.2
+ dev-libs/libxml2
+ >=sys-fs/cryptsetup-1.0.5
+ sys-process/lsof"
+
+src_compile() {
+ econf --with-slibdir="/$(get_libdir)" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/*.txt || die "dodoc failed"
+}