summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-11-05 09:51:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-11-05 09:51:14 +0000
commit9af3cdbf643af68526b654ff3c3238d02e686020 (patch)
tree98fe4df5e7d6f63ac1b26a8f401b37fb282061ac /sys-auth
parentVersion bump, wrt bug #527860. Fix manpage installation path, use correct pkg... (diff)
downloadgentoo-2-9af3cdbf643af68526b654ff3c3238d02e686020.tar.gz
gentoo-2-9af3cdbf643af68526b654ff3c3238d02e686020.tar.bz2
gentoo-2-9af3cdbf643af68526b654ff3c3238d02e686020.zip
Version bump to ConsoleKit2 from github from where the xfce4-power-manager author has picked up the code. Masked for testing.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/ChangeLog8
-rw-r--r--sys-auth/consolekit/consolekit-0.9.2.ebuild108
2 files changed, 115 insertions, 1 deletions
diff --git a/sys-auth/consolekit/ChangeLog b/sys-auth/consolekit/ChangeLog
index c6f0b8595a5f..dca83e976f83 100644
--- a/sys-auth/consolekit/ChangeLog
+++ b/sys-auth/consolekit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/consolekit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.173 2014/08/14 08:47:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/ChangeLog,v 1.174 2014/11/05 09:51:14 ssuominen Exp $
+
+*consolekit-0.9.2 (05 Nov 2014)
+
+ 05 Nov 2014; Samuli Suominen <ssuominen@gentoo.org> +consolekit-0.9.2.ebuild:
+ Version bump to ConsoleKit2 from github from where the xfce4-power-manager
+ author has picked up the code. Masked for testing.
14 Aug 2014; Jeroen Roovers <jer@gentoo.org> consolekit-0.4.6.ebuild:
Stable for HPPA (bug #519870).
diff --git a/sys-auth/consolekit/consolekit-0.9.2.ebuild b/sys-auth/consolekit/consolekit-0.9.2.ebuild
new file mode 100644
index 000000000000..a8e4cd3a0022
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-0.9.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.9.2.ebuild,v 1.1 2014/11/05 09:51:14 ssuominen Exp $
+
+EAPI=5
+inherit eutils linux-info pam
+
+MY_PN=ConsoleKit2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats"
+HOMEPAGE="http://github.com/ConsoleKit2/ConsoleKit2 http://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="http://github.com/${MY_PN}/${MY_PN}/releases/download/${PV}/${MY_P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_0.4.6-4.debian.tar.gz" # for logrotate file"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="acl debug doc kernel_linux pam policykit selinux test"
+
+# TODO: Cleanup the || () hack later, like end of the year:
+# Skip certain broken glib 2.38 releases wrt #501330
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
+ || ( >=dev-libs/glib-2.38.2-r1:2 <dev-libs/glib-2.38:2 )
+ >=dev-libs/glib-2.22:2=
+ sys-libs/zlib:=
+ x11-libs/libX11:=
+ acl? (
+ sys-apps/acl:=
+ >=virtual/udev-200
+ )
+ pam? ( virtual/pam )
+ policykit? ( >=sys-auth/polkit-0.110 )"
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/coreutils[acl?] )
+ selinux? ( sec-policy/selinux-consolekit )"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+QA_MULTILIB_PATHS="usr/lib/ConsoleKit/.*"
+
+pkg_setup() {
+ if use kernel_linux; then
+ # This is from http://bugs.gentoo.org/376939
+ use acl && CONFIG_CHECK="~TMPFS_POSIX_ACL"
+ # This is required to get login-session-id string with pam_ck_connector.so
+ use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
+}
+
+src_configure() {
+ econf \
+ XMLTO_FLAGS='--skip-validation' \
+ --libexecdir="${EPREFIX}"/usr/lib/ConsoleKit \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable pam pam-module) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable test docbook-docs) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable acl udev-acl) \
+ --with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
+ --with-pam-module-dir="$(getpam_mod_dir)" \
+ --with-logrotate-dir=/etc/logrotate.d \
+ --with-xinitrc-dir=/etc/X11/xinit/xinitrc.d \
+ --without-systemdsystemunitdir
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dosym /usr/lib/ConsoleKit /usr/lib/${PN}
+
+ dodoc AUTHORS HACKING NEWS README TODO
+
+ newinitd "${FILESDIR}"/${PN}-0.2.rc consolekit
+
+ keepdir /usr/lib/ConsoleKit/run-seat.d
+ keepdir /usr/lib/ConsoleKit/run-session.d
+ keepdir /etc/ConsoleKit/run-session.d
+ keepdir /var/log/ConsoleKit
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/90-consolekit-3 90-consolekit
+
+ prune_libtool_files --all # --all for pam_ck_connector.la
+
+ rm -rf "${ED}"/var/run # let the init script create the directory
+
+ insinto /etc/logrotate.d
+ newins "${WORKDIR}"/debian/${PN}.logrotate ${PN} #374513
+}