summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-07-26 23:13:04 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-07-26 23:13:04 +0000
commit9f11232ea137e9b4eda9494a24c2f0458ca6854c (patch)
treef84a0086084599e733efe898d3b689fa127946f5 /sys-auth
parentbetter sqlalchemy deps (diff)
downloadgentoo-2-9f11232ea137e9b4eda9494a24c2f0458ca6854c.tar.gz
gentoo-2-9f11232ea137e9b4eda9494a24c2f0458ca6854c.tar.bz2
gentoo-2-9f11232ea137e9b4eda9494a24c2f0458ca6854c.zip
better sqlalchemy deps
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog7
-rw-r--r--sys-auth/keystone/keystone-2014.1.1-r2.ebuild24
-rw-r--r--sys-auth/keystone/keystone-2014.1.9999.ebuild25
-rw-r--r--sys-auth/keystone/keystone-9999.ebuild25
4 files changed, 60 insertions, 21 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 36e4106e07ed..e48e6e8811af 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.75 2014/07/06 12:56:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.76 2014/07/26 23:13:04 prometheanfire Exp $
+
+ 26 Jul 2014; Matthew Thode <prometheanfire@gentoo.org>
+ keystone-2014.1.1-r2.ebuild, keystone-2014.1.9999.ebuild,
+ keystone-9999.ebuild:
+ better sqlalchemy deps
06 Jul 2014; Michał Górny <mgorny@gentoo.org> keystone-9999.ebuild:
Clean up obsolete dependencies on virtual/python-argparse and virtual/python-
diff --git a/sys-auth/keystone/keystone-2014.1.1-r2.ebuild b/sys-auth/keystone/keystone-2014.1.1-r2.ebuild
index 3e1486547baf..c9032fc2750c 100644
--- a/sys-auth/keystone/keystone-2014.1.1-r2.ebuild
+++ b/sys-auth/keystone/keystone-2014.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.1-r2.ebuild,v 1.1 2014/07/02 17:12:34 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.1-r2.ebuild,v 1.2 2014/07/26 23:13:04 prometheanfire Exp $
EAPI=5
@@ -57,11 +57,23 @@ RDEPEND=">=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
>=dev-python/six-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-0.7.8[${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
- sqlite? ( dev-db/sqlite )
+ sqlite? (
+ >=dev-python/sqlalchemy-0.8.0[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[sqlite,${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[sqlite,${PYTHON_USEDEP}]
+ )
+ mysql? (
+ dev-python/mysql-python
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ dev-python/psycopg:2
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ )
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-2014.1.9999.ebuild b/sys-auth/keystone/keystone-2014.1.9999.ebuild
index 15312fc35f8d..ad4eaa29ec31 100644
--- a/sys-auth/keystone/keystone-2014.1.9999.ebuild
+++ b/sys-auth/keystone/keystone-2014.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.9999.ebuild,v 1.3 2014/06/30 01:30:42 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2014.1.9999.ebuild,v 1.4 2014/07/26 23:13:04 prometheanfire Exp $
EAPI=5
@@ -57,12 +57,23 @@ RDEPEND=">=dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
>=dev-python/six-1.6.0[${PYTHON_USEDEP}]
- sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
- <=dev-python/sqlalchemy-0.9.99[sqlite,${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
- <=dev-python/sqlalchemy-0.9.99[mysql,${PYTHON_USEDEP}] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
- <=dev-python/sqlalchemy-0.9.99[postgres,${PYTHON_USEDEP}] )
+ sqlite? (
+ >=dev-python/sqlalchemy-0.8.0[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[sqlite,${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[sqlite,${PYTHON_USEDEP}]
+ )
+ mysql? (
+ dev-python/mysql-python
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ dev-python/psycopg:2
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ )
>=dev-python/sqlalchemy-migrate-0.9[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]
diff --git a/sys-auth/keystone/keystone-9999.ebuild b/sys-auth/keystone/keystone-9999.ebuild
index 031cdca5eb8f..22cd5f660540 100644
--- a/sys-auth/keystone/keystone-9999.ebuild
+++ b/sys-auth/keystone/keystone-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.17 2014/07/06 12:56:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-9999.ebuild,v 1.18 2014/07/26 23:13:04 prometheanfire Exp $
EAPI=5
@@ -54,12 +54,23 @@ RDEPEND=">=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
>=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
dev-python/paste[${PYTHON_USEDEP}]
>=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
- sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.7.99[sqlite,${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.7.99[mysql,${PYTHON_USEDEP}] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.7.99[postgres,${PYTHON_USEDEP}] )
+ sqlite? (
+ >=dev-python/sqlalchemy-0.8.0[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[sqlite,${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[sqlite,${PYTHON_USEDEP}]
+ )
+ mysql? (
+ dev-python/mysql-python
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ dev-python/psycopg:2
+ >=dev-python/sqlalchemy-0.8.0[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-0.9.5[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ )
>=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
dev-python/passlib[${PYTHON_USEDEP}]
>=dev-python/lxml-2.3[${PYTHON_USEDEP}]