summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2013-08-10 12:37:25 +0000
committerWolfram Schlich <wschlich@gentoo.org>2013-08-10 12:37:25 +0000
commita6cc5dd7b630af2d6d6d608cf6f991b00a0f7b2f (patch)
tree954375b912e18d908f4da6ba71f04a7fa29e865d /sys-auth
parentBump (diff)
downloadgentoo-2-a6cc5dd7b630af2d6d6d608cf6f991b00a0f7b2f.tar.gz
gentoo-2-a6cc5dd7b630af2d6d6d608cf6f991b00a0f7b2f.tar.bz2
gentoo-2-a6cc5dd7b630af2d6d6d608cf6f991b00a0f7b2f.zip
version bump
(Portage version: 2.2.0_alpha194/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ykpers/ChangeLog7
-rw-r--r--sys-auth/ykpers/ykpers-1.14.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-auth/ykpers/ChangeLog b/sys-auth/ykpers/ChangeLog
index df7fe8c0f98c..a6ec5a856631 100644
--- a/sys-auth/ykpers/ChangeLog
+++ b/sys-auth/ykpers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/ykpers
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.9 2013/04/22 13:23:20 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ChangeLog,v 1.10 2013/08/10 12:37:25 wschlich Exp $
+
+*ykpers-1.14.0 (10 Aug 2013)
+
+ 10 Aug 2013; Wolfram Schlich <wschlich@gentoo.org> +ykpers-1.14.0.ebuild:
+ version bump
*ykpers-1.13.0 (22 Apr 2013)
diff --git a/sys-auth/ykpers/ykpers-1.14.0.ebuild b/sys-auth/ykpers/ykpers-1.14.0.ebuild
new file mode 100644
index 000000000000..31a850920bf0
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.14.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/ykpers/ykpers-1.14.0.ebuild,v 1.1 2013/08/10 12:37:25 wschlich Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND=">=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ dodoc doc/*
+ prune_libtool_files
+
+ use consolekit && \
+ udev_dorules 70-yubikey.rules
+}